Closed Bug 945960 Opened 8 years ago Closed 3 years ago

tieba.baidu.com serves desktop content to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: karlcow, Assigned: yliu)

References

()

Details

(Whiteboard: [mobile-compat-form] [country-cn] [serversniff] [sitewait])

Attachments

(1 file)

Site: http://tieba.baidu.com/
tieba.baidu.com serves desktop content to Firefox OS

:: Steps To Reproduce

1. with Firefox OS, ZTE
2. Go to http://tieba.baidu.com/


:: Expected Result

Receive a mobile friendly content like it is happening for Safari iOS.

:: Actual Result

Received the Desktop Content.

:: Additional Information

Software Version: 1.1
Device Information: ZTE roamer2
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → ARM
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-cn] [serversniff]
GET / HTTP/1.1
User-Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3
Host: tieba.baidu.com

HTTP/1.1 200 OK
Date: Thu, 26 Dec 2013 12:26:12 GMT
Content-Type: text/html; charset=utf-8
Connection: Keep-Alive
Vary: Accept-Encoding
Vary: Accept-Encoding
Set-Cookie: BAIDU_WISE_UID=wapp_1388060772241_288; expires=Sat, 19-Dec-2043 12:26:12 GMT; path=/; domain=.baidu.com
Set-Cookie: IS_NEW_USER=29fdeceb8d3de9a65328b785; expires=Thu, 31-Dec-2020 15:59:59 GMT; path=/; domain=cp01-orp-app47.cp01.baidu.com
Set-Cookie: mo_originid=2; path=/
Set-Cookie: BAIDUID=3E1AE6EDD0336361101D7E4E29C9154D:FG=1; expires=Fri, 26-Dec-14 12:26:12 GMT; max-age=31536000; path=/; domain=.baidu.com; version=1
tracecode: 15723294660942431242122620
tracecode: 15723294660958946314122620
P3P: CP=" OTI DSP COR IVA OUR IND COM "
Server: Apache
Content-Length: 33192

------------------------------------------------------------------
GET / HTTP/1.1
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0
Host: tieba.baidu.com

HTTP/1.1 200 OK
Date: Thu, 26 Dec 2013 12:27:58 GMT
Content-Type: text/html; charset=GBK
Connection: Keep-Alive
Vary: Accept-Encoding
Vary: Accept-Encoding
Set-Cookie: TIEBA_USERTYPE=87db289f30c9331b7b31dd85; expires=Thu, 31-Dec-2020 15:59:59 GMT; path=/; domain=tieba.baidu.com
Set-Cookie: TIEBAUID=cb23caae14130a0d384a57f1; expires=Thu, 31-Dec-2020 15:59:59 GMT; path=/; domain=tieba.baidu.com
Set-Cookie: BAIDUID=BD14728FCEDB3D301FDA2DE5E7D4D75E:FG=1; expires=Fri, 26-Dec-14 12:27:58 GMT; max-age=31536000; path=/; domain=.baidu.com; version=1
tracecode: 16780863010376844298122620
tracecode: 16780863010873669642122620
P3P: CP=" OTI DSP COR IVA OUR IND COM "
Server: Apache
Content-Length: 152433

------------------------------------------------------------------
Whiteboard: [mobile-compat-form] [country-cn] [serversniff] → [mobile-compat-form] [country-cn] [serversniff] [contactready]
On second thought, I want to analyze those sites a bit more before labelling them as contactready ;)..
Whiteboard: [mobile-compat-form] [country-cn] [serversniff] [contactready] → [mobile-compat-form] [country-cn] [serversniff]
Report of CSS problems noted on tieba.baidu.com
Whiteboard: [mobile-compat-form] [country-cn] [serversniff] → [mobile-compat-form] [country-cn] [serversniff] [contactready]
See Also: → 945963
Duplicate of this bug: 965613
Assignee: nobody → yliu
Status: NEW → ASSIGNED
contact baidu already but they do't have plan to fix in short term.
Whiteboard: [mobile-compat-form] [country-cn] [serversniff] [contactready] → [mobile-compat-form] [country-cn] [serversniff] [sitewait]
Firefox OS receives Desktop
Firefox Android receives simplified content. bug 945963
Chrome receives a modern mobile site.
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.