Closed Bug 945976 Opened 6 years ago Closed 6 years ago

"TypeError: this._contentWindow is null" when pasting from action bar

Categories

(Firefox for Android :: Text Selection, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 950464
Tracking Status
fennec 28+ ---

People

(Reporter: Margaret, Assigned: capella)

References

Details

I don't always run into this, but I am seeing it on both Nightly and my local build:
[JavaScript Error: "TypeError: this._contentWindow is null" {file: "chrome://browser/content/SelectionHandler.js" line: 191}]

This corresponds to the reference in _getScrollPos, which is called from _positionHandles. My guess is that we're trying to call _positionHandles when there isn't an active selection.
Assignee: nobody → markcapella
Flags: needinfo?(wjohnston)
In the patch I posted for https://bugzilla.mozilla.org/page.cgi?id=splinter.html&bug=947284&attachment=8345716

I'd included a check for |if (!caretPos) { return; }| after call to _moveSelection().this._contentWindow.document.caretPositionFromPoint() ...

In testing for that bug, I saw it failing while dragging handles off screen past physical limts

Pretty sure that's the thing here ... I'll post a patch?
I just posted an update patch to bug 947284 that re-iterates it fixs that patch, as well as this one.

They're part and parcel, and not a terribly complex issue. I'd prefer in this case to fix both at once.

Testcase for both posted in bug 947284.
Status: NEW → ASSIGNED
Watching things develop, wesj's fix for bug 950464 is headed into fx-team, is a dup of this issue, and testing shows also fixs this issue.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 950464
Flags: needinfo?(wjohnston)
You need to log in before you can comment on or make changes to this bug.