about:start no longer displays scrollbars

VERIFIED FIXED in Firefox 28

Status

Firefox for Metro
Firefox Start
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jimm, Assigned: mbrubeck)

Tracking

({regression})

Trunk
Firefox 28
All
Windows 8.1
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox27 unaffected, firefox28+ verified, firefox29 verified)

Details

(Whiteboard: [beta28] p=1)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
This regressed in bug 902505. Commenting out updateViewport code fixes it.

Updated

4 years ago
Blocks: 838081
Whiteboard: [triage]

Updated

4 years ago
Whiteboard: [triage] → [beta28]

Updated

4 years ago
Whiteboard: [beta28] → [beta28] p=0
(Assignee)

Updated

4 years ago
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Keywords: regression
(Assignee)

Comment 1

4 years ago
Created attachment 8344131 [details] [diff] [review]
patch

We were setting an incorrect CSS viewport for the start page, because we shrink the browser on about:start to account for the navbar.

While testing this I also noticed that we set "about:home" as an alias for "about:start" in AboutRedirector.js, but weren't treating it like the start page in BrowserUI.  This patch also fixes that.
Attachment #8344131 - Flags: review?(msamuel)
(Assignee)

Comment 2

4 years ago
Comment on attachment 8344131 [details] [diff] [review]
patch

There seems to be a timing issue with this patch; it doesn't set the correct viewport when switching from a non-about:start page to an about:start page, probably because the padding hasn't been adjusted yet.  Working on a fix.
Attachment #8344131 - Flags: review?(msamuel)
(Assignee)

Comment 3

4 years ago
Created attachment 8344199 [details] [diff] [review]
patch v2

This adds code to update the viewport after we resize the browser when the start page loads or unloads.
Attachment #8344131 - Attachment is obsolete: true
Attachment #8344199 - Flags: review?(msamuel)
Hey Matt, can you provide a point value.
Blocks: 947326
No longer blocks: 838081
Flags: needinfo?(mbrubeck)
Priority: -- → P2
QA Contact: jbecerra
(Assignee)

Comment 5

4 years ago
(In reply to Marco Mucci [:MarcoM] from comment #4)
> Hey Matt, can you provide a point value.

p=1
Flags: needinfo?(mbrubeck)

Updated

4 years ago
Whiteboard: [beta28] p=0 → [beta28] p=1
Comment on attachment 8344199 [details] [diff] [review]
patch v2

Review of attachment 8344199 [details] [diff] [review]:
-----------------------------------------------------------------

Code looks good to me. Though for some reason, I do see the scrollbar with a pull from this morning without the patch. Not sure if it's perhaps the screen resolution affecting it or something else? But ok if it works for you.
Attachment #8344199 - Flags: review?(msamuel) → review+
https://hg.mozilla.org/mozilla-central/rev/5e20f6d0c911
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
(Assignee)

Comment 8

4 years ago
Comment on attachment 8344199 [details] [diff] [review]
patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 902505

User impact if declined: Can't scroll Metro start page with mouse.

Testing completed (on m-c, etc.): Baked on m-c since 12/9.

Risk to taking this patch (and alternatives if risky): Low-risk Metro-only patch.

String or IDL/UUID changes made by this patch: None.
Attachment #8344199 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
status-firefox27: --- → unaffected
status-firefox28: --- → affected
status-firefox29: --- → fixed
tracking-firefox28: --- → ?
Attachment #8344199 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-firefox28: ? → +
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e51e3611210a
status-firefox28: affected → fixed
Hardware: x86_64 → All
(Reporter)

Updated

4 years ago
Target Milestone: Firefox 29 → Firefox 28
Verified using latest nightly and latest aurora builds on Windows 8.1 (32bit and 64bit). 
The scrollbars are now shown on about:start.
Status: RESOLVED → VERIFIED
status-firefox28: fixed → verified
status-firefox29: fixed → verified
You need to log in before you can comment on or make changes to this bug.