Closed Bug 946340 Opened 6 years ago Closed 6 years ago

Split view about:start pages don't touch scroll

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect, P2)

28 Branch
All
Windows 8.1
defect

Tracking

(firefox27 unaffected, firefox28+ verified, firefox29 verified)

RESOLVED FIXED
Firefox 28
Tracking Status
firefox27 --- unaffected
firefox28 + verified
firefox29 --- verified

People

(Reporter: jimm, Assigned: mbrubeck)

References

Details

(Whiteboard: [beta28] p=5)

Attachments

(1 file)

1/2 split view doesn't seem to scroll via touch, but works with the mouse wheel.
I wonder if this has something to do with scroll lock in the apzc. When in split view, I can select tiles horizontally, but can't scroll up/down. Once I resize to normal view, I can vertically select tiles, and can scroll horizontally.
Whiteboard: [triage] → [beta28] p=0
Taking this for iteration 21; estimated effort p=5
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Whiteboard: [beta28] p=0 → [beta28] p=5
Blocks: metrov1it21
No longer blocks: metrov1backlog
Priority: -- → P2
QA Contact: jbecerra
Attached patch patchSplinter Review
Well, that was simpler than I thought.  Our stylesheet explicitly disabled vertical scrolling on about:start, but this had no effect on touch scrolling until bug 942995 was fixed.

This patch just swaps the overflow properties when we switch to the vertical layout.
Attachment #8346043 - Flags: review?(ally)
Comment on attachment 8346043 [details] [diff] [review]
patch

Review of attachment 8346043 [details] [diff] [review]:
-----------------------------------------------------------------

Easiest patch I've had to review in a long time. ship it
Attachment #8346043 - Flags: review?(ally) → review+
https://hg.mozilla.org/mozilla-central/rev/9b247e7fc91f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Comment on attachment 8346043 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 942995

User impact if declined: Touch-screen users can't scroll the Firefox start page in portrait-oriented windows.

Testing completed (on m-c, etc.): Landed on m-c 12/12.

Risk to taking this patch (and alternatives if risky): Low-risk metro-only patch.
 
String or IDL/UUID changes made by this patch: None.
Attachment #8346043 - Flags: approval-mozilla-aurora?
Attachment #8346043 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/0e3bd70f2295
Hardware: x86_64 → All
Version: Trunk → 28 Branch
Target Milestone: Firefox 29 → Firefox 28
Went through the following issue for iteration #21 without any issues. Used the following builds:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-12-00-40-02-mozilla-aurora/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-12-03-02-04-mozilla-central/

- Ensured that the about:start screen scrolls horizontally when Firefox Metro fills the entire width
- Ensured that the about:start screen scrolls vertically when Firefox Metro fills the screen 1/2
- Ensured that resizing the Firefox Metro window appropriately reshuffles the tiles under about:screen and the correct scrolling is being used (vertical/horizontally)
- Ensured that you can scroll through websites by swiping vertically while Firefox Metro is using 1/2 and other width sizes
- Ensured that scrolling via mouse wheel/touch works without any issues
- Ensured that all of the above test cases work with both left & right sides of the screen

There's several issues/improvements I noticed when resizing the Firefox Metro window when going through this bug. I will create separate tickets as this just concentrates on the scrolling aspect.
You need to log in before you can comment on or make changes to this bug.