Closed Bug 946411 Opened 8 years ago Closed 8 years ago

Page zoomed when switching from portrait to landscape

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 938312

People

(Reporter: nbp, Unassigned)

Details

(Keywords: regression)

Vivien show me a similar example with async-pan-zoom, but I am making builds out of inbound without any special option to enable async-pan-zoom.

STR:
 - Put the phone in landscape mode.
 - Tap the browser icon, to open the browser application
 - Navigate to people.mozilla.org/~npierron/octane/index.html
 * Wait until the page is loaded
 - Tap the home button
 - Tap the browser icon, to switch back to the browser application

Expected:
 - The browser app should open in landscape mode and show the same content as before.

Seen:
 - The browser app open in portait.
 - Render the content to the dimension of the landscape (I presume)
 - Rotate & Scale the content of the portait view in the landscape view.
  => This cause the page to appeared as being zoomed on the top-left corner of the page.

This STR cannot be reproduced on v1.2.
Component: Gaia::Browser → Panning and Zooming
Product: Firefox OS → Core
Can someone get a screenshot here? I think the rectangle issue seen here is bug 940257.
blocking-b2g: --- → 1.3?
Also, is this the same issue as bug 938312?
(In reply to Jason Smith [:jsmith] from comment #1)
> Can someone get a screenshot here? I think the rectangle issue seen here is
> bug 940257.

After looking at the screenshot (attachment 8333734 [details]), the problem seems different and newer.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> Also, is this the same issue as bug 938312?

The STR sounds identical, and the zoom issue is also debate in this other bug.
Thanks for finding the duplicated bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938312
blocking-b2g: 1.3? → ---
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.