Closed Bug 946522 Opened 8 years ago Closed 7 years ago

getAccounts not working after leaving and returning to app

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 934011

People

(Reporter: edwong, Assigned: ferjm)

References

Details

(Whiteboard: [qa+])

1. flash custom fxa gecko/gaia on hamachi (what i'm on)
2. launch test fxa client app
3. click launch fxaccounts flow
4. enter in email and password, click done
5. click home button
6. click test fxa client app
7. click Get Fx Accounts

result: screen says connecting to firefox forever.  The only way to recover is the adb shell rm ... signedInUser.json file

expected: you should see result text No Params
this is a blocking bug to signing in more than once on device.  and having to use adb to recover and restart isn't fun.
logout is the same after you leave the app
Thanks, Edwin.  This one was probably neglected because logout was actually not part of the target mvp.  But it should certainly be an easy fix.
Whiteboard: [qa+]
Summary: getFxAccounts not working after leaving and returning to app → getAccounts not working after leaving and returning to app
Assignee: nobody → ferjmoreno
This issue was fixed by bug 934011
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 934011
OK. Verifying as a Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.