Closed Bug 946588 Opened 6 years ago Closed 6 years ago

UI still indicated airplane mode is on while it's off after dialing out emergency call.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, firefox29 fixed, b2g-v1.3 fixed)

VERIFIED FIXED
blocking-b2g 1.3+
Tracking Status
firefox29 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: echu, Assigned: eragonj)

References

Details

(Keywords: regression, Whiteboard: [Fugu][dsds_US_test][FT:System-Platform][v1.2f-uplift-needed])

Attachments

(1 file)

When device is under airplane mode, dial out emergency call, airplane mode icon is still on status bar, and "SIM card not ready" is shown under Call/messaging/Cellular & Data settings. But MT/MO call and data call are already working at this point that somehow I think airplane mode is off.

* Build Number                
Fugu
Gaia      def4baa9ad44843ea214b6f94d04c29613cbfadb
Gecko     8c89455659d2ab56e9e56b7591f0982bed638e0e
BuildID   20131205103217
Version   28.0a1

* Reproduce Steps
1. Turn on airplane mode.
2. Dial 911.
3. Call will be dialed out after couple seconds.

* Expected Result
Airplane mode UI will be off.

* Actual Result
Airplane mode UI is still on, and "SIM card not ready" is shown under Call/messaging/Cellular & Data settings.

* Occurrence rate
100%
blocking-b2g: --- → 1.3?
Whiteboard: [dsds_US_test]
Component: Gaia → Gaia::System
Whiteboard: [dsds_US_test] → [dsds_US_test][FT:System-Platform]
Triage: this is a regression according to UA since the behavior is different.

EJ, did we do anything on Airplane mode handling recently?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(ejchen)
Keywords: regression
Summary: [DSDS] UI still indicated airplane mode is on while it's off after dialing out emergency call. → UI still indicated airplane mode is on while it's off after dialing out emergency call.
Not sure whether this is a new test case or not. Currently we are working on bug 948847 to fix airplane mode timing issue as what we have explained in the meeting. I still remembered that the new helper has been tested and worked well on all airplane mode test cases on mozTrap. If this is the timing issue, then this will be fixed after landing bug 948847. 

I will ask Enpei more about this test case. Thanks Tim !
Flags: needinfo?(ejchen)
Blocks: 956203
Duplicate of this bug: 952896
Whiteboard: [dsds_US_test][FT:System-Platform] → [Fugu][dsds_US_test][FT:System-Platform][v1.2f-uplift-needed]
After discussing with Arthur, we found the root cause of this bug. The reason why the UI is not consistent is because before v1.3, we use mozSetting key to indicate Gecko & Gaia about whether we are in airplane mode or not. But after v1.3, Gecko will not directly change the mozSetting key about airplane mode change.

I will add a bridge at system app /airplane_mode.js about this case and update airplane mode at right time to change mozSetting key to notify them we are leaving airplane mode to make UI consistent.
Assignee: nobody → ejchen
Hi ej,
how is it going?
Flags: needinfo?(ejchen)
(In reply to sam.hua from comment #5)
> Hi ej,
> how is it going?

AirplaneModeHelper is almost done and Arthur is doing the final review now. After it is landed, this bug will be fixed.

Thanks.
Depends on: 948847
Flags: needinfo?(ejchen)
Component: Gaia::System → Gaia::Settings
Hi Enpei,

this bug has been fixed after landing bug 948847 ! Thanks ;)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Buri is fixed, yet Fugu still have the bug, will open another one for tracking.

Buri
Gaia      50d6487d4d15efda942c934570e6fdfb91f6fe2e
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/2e9d1f109655
BuildID   20140119004001
Version   28.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.