Closed Bug 946605 Opened 7 years ago Closed 7 years ago

No Nightly l10n builds for Mac OS X after Dec 2

Categories

(Firefox Build System :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla28

People

(Reporter: flod, Assigned: glandium)

References

Details

Attachments

(1 file, 2 obsolete files)

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/

OS X build for en-US is from Dec 4

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/

All l10n builds for OS X stop on on Dec 2.

Since tinderbox went away I don't think we have any way to find info about l10n builds (at least I don't).

FTP log for Italian
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-12-04-03-02-03-mozilla-central-l10n/mozilla-central-macosx64-l10n-nightly-it-bm86-build1-build332.txt.gz

configure: error: in `/builds/slave/m-cen-osx64-l10n-ntly-00000000/build/mozilla-central/obj-firefox/i386/js/src/ctypes/libffi':
configure: error: C compiler cannot create executables
See `config.log' for more details.
configure: error: /builds/slave/m-cen-osx64-l10n-ntly-00000000/build/mozilla-central/js/src/ctypes/libffi/configure failed for ctypes/libffi
configure: error: /builds/slave/m-cen-osx64-l10n-ntly-00000000/build/mozilla-central/js/src/configure failed for js/src
*** Fix above errors and then restart with               "make -f client.mk build"
make: *** [configure] Error 1
program finished with exit code 2
elapsedTime=47.543563
Summary: No l10n builds for Mac OS X after Dec 2 → No Nightly l10n builds for Mac OS X after Dec 2
The one for Dec 3 is:
rsync: link_stat "/builds/slave/m-cen-osx64-l10n-ntly-00000000/build/mozilla-central/obj-firefox/i386/dist/unpack.tmp/.background/`basename /builds/slave/m-cen-osx64-l10n-ntly-00000000/build/mozilla-central/obj-firefox/i386/dist/branding/background.png`" failed: No such file or directory (2)

and is caused by bug 943728

On Dec 2, it was an infrastructure problem and didn't affect other locales.
Blocks: 943728
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
$ hg log -r 8648aa476eef:9688476c1544 configure.in js/src/configure.in build/autoconf
changeset:   158680:838f865fa1c7
user:        Nathan Froyd <froydnj@mozilla.com>
date:        Fri Nov 08 11:38:02 2013 -0500
summary:     Bug 933231 - don't |unset| variables after configuring NSPR; r=ted
Blocks: 933231
That bug was already backed out on inbound, so next l10n build after the next merge should fail like the one on Dec 3, which failure the patch attached here addresses.
Leftover backquote.
Attachment #8342949 - Flags: review?(mshal)
Attachment #8342945 - Attachment is obsolete: true
Attachment #8342945 - Flags: review?(mshal)
Hum, the patch title was obviously wrong.
Attachment #8342950 - Flags: review?(mshal)
Attachment #8342949 - Attachment is obsolete: true
Attachment #8342949 - Flags: review?(mshal)
Attachment #8342950 - Flags: review?(mshal) → review+
Duplicate of this bug: 946616
https://hg.mozilla.org/mozilla-central/rev/1401e4b394ad
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Keywords: verifyme
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 28 → mozilla28
You need to log in before you can comment on or make changes to this bug.