Closed Bug 946678 Opened 6 years ago Closed 6 years ago

[Messaging] Creating a new message from contacts does not open the messaging composer when Messaging app is in background

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, firefox28 affected, b2g-v1.3 fixed)

VERIFIED FIXED
blocking-b2g 1.3+
Tracking Status
firefox28 --- affected
b2g-v1.3 --- fixed

People

(Reporter: isabelrios, Assigned: julienw)

References

Details

(Keywords: regression)

Attachments

(1 file)

12/05 Master build:
Gecko-c37a72b
Gaia-6a20f5a

STR
There should be a contact with phone number stored in the device.
1. Open Messaging app
2. Tap on Home key to leave it in background
3. Open contacts app -> Select one contact
4. On the details view, tap on 'message' icon to send a message

EXPECTED
The composer messaging view is open with the field 'To' pre-filled with the contact's name

ACTUAL
When tapping on message icon, Messaging app is open but in the messages list view, not in the composer one.
Duplicate of this bug: 942759
QA Contact: gbennett
.:Last Working Build:.
Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131024154023
Gaia: 2feebdb1a2583928f32407d76d798f8654621e2b
Gecko: 19fd3388c372
Version: 27.0a1
Firmware Version: 20131115

.:First Broken Build:.
Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131025040252
Gaia: 15c1089aea0490b9b73bc915b1495b3faa1b023c
Gecko: 5a9ac6fed6ff
Version: 27.0a1
Firmware Version: 20131115
Probably a regression from bug 815093 then.
Blocks: 815093
I think I don't understand how inline activities work.

If I continue the STR with these steps:

5. press home
6. open the Messages app from the icon
=> the behavior shown is what was expected in the first place

So it means the SMS app is doing correctly the intended actions, but not in the good "window".

Alive, can you please help me understand how this works?
Flags: needinfo?(alive)
Discussing with folks here, I think the system message is not sent to the right window.
The SMS app is the only app with an inline activity that does not specify a specific href page, so that could be the reason it happens only here.
This is happening because of bug 931339.

Now we can workaround it by adding a different href to the activity. Will do that now.
Assignee: nobody → felash
Flags: needinfo?(alive)
Attached patch patch v1Splinter Review
Adds a hash for the "new" activity. This will have the side-effect of not
registering the notification and sms-received system message handlers which is a
good thing.
---
 apps/sms/manifest.webapp |    1 +
 1 file changed, 1 insertion(+)

The github pull request is: https://github.com/mozilla-b2g/gaia/pull/14463

Note: you'll need to use "make reset-gaia" to update the activities.
Attachment #8343735 - Flags: review?(borja.bugzilla)
Hey Zac,

I don't know if you already have an integration test for the "send sms" activity from the Contacts app. We need to have an integration test for this activity, and with three cases:
* once with the messages app already started in background
* once with the messages app closed
* twice with the messages app closed (ie. pressing "home" after launching the activity, relaunching the Contacts app, and restarting the activity)
Flags: needinfo?(zcampbell)
triage: regression. 1.3+
blocking-b2g: 1.3? → 1.3+
This reminds me to it's better to have a diagram chart to describe how system message works in window management.
Comment on attachment 8343735 [details] [diff] [review]
patch v1

Review of attachment 8343735 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Julien for identifying the issue here, it's quite tough to identify the issue and with the workaround is working (I've not found any other regression). Thanks for the quick patch.

On the other hand Im wondering if 'Share' activity needs as well to be inline, Wdyt? Do we have any bug for working on this?
Attachment #8343735 - Flags: review?(borja.bugzilla) → review+
(In reply to Borja Salguero [:borjasalguero] from comment #12)
> Comment on attachment 8343735 [details] [diff] [review]
> patch v1
> 
> Review of attachment 8343735 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thanks Julien for identifying the issue here, it's quite tough to identify
> the issue and with the workaround is working (I've not found any other
> regression). Thanks for the quick patch.
> 
> On the other hand Im wondering if 'Share' activity needs as well to be
> inline, Wdyt? Do we have any bug for working on this?

Yep, this is bug 936729 :)

thanks for the review!
master: 9bc5f1fd67b42404db3e80e7ef5eb8b9f0802c59
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Clearing in? as julienw filed these as individual tasks.
Flags: needinfo?(zcampbell)
Uplifted 9bc5f1fd67b42404db3e80e7ef5eb8b9f0802c59 to:
v1.3: 5861e78e94c5d5e23be63bc42ea4bbc3df1ef43a
Verified on latest buri 1.3 build (01/08):

Gecko-e499b1f
Gaia-d578331

The Messages app is open correctly in message composer view.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.