[Australis] When starting firefox and the tab-bar is overflowing, tabs are scrolled so that the selected tab is the leftmost visible tab and this tab's left curve is sometimes cut off by the "scroll-left"-button.

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Johan C, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8343129 [details]
australis_tabbar_overlow_first_tab.jpg

When starting Firefox with an overflowed tab-bar, the selected tab is scroll into view (if necessary) and placed at the start of the tab-bar, making it the leftmost visible tab.

Firefox should remember the scroll position of the tab-bar (at least if the selected tab was already in view when closing/restarting Firefox. The left tab curve (Australis theme) should also not be cut off by the button used to scroll the tab-bar to the left.

STR:
  1. Open enough tabs to overflow the tab-bar.
  2. Restart Firefox (I can't reproduce this bug every time I start Firefox).

Actual result: The selected tab's left curve is cut off and the tab-bar does not remember its scroll position.
(Reporter)

Comment 1

4 years ago
I should add that it is not possible to scroll the tab-bar left with the mouse wheel when this happens. It is however possible to scroll right with the mouse wheel, and left with the button to the left of the tab-container.
Blocks: 732583, 738491
No longer depends on: 732583, 738491
I believe remembering the scroll position would be confusing: that's more of a temporary interaction (scroll to find something, then select it), and would often feel like a bug when when you restart and find a tab loaded but not visible in the tabstrip.

Pretty sure there's another bug covering the cut-off tab (possibly fixed), if you're still seeing it please file a new bug for that specifically. (One issue per bug, please.)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Duplicate of this bug: 973340
You need to log in before you can comment on or make changes to this bug.