Clicking on the borders of bookmarks widget in the panel makes a panel appear

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ge3k0s, Assigned: Gijs)

Tracking

(Blocks 1 bug)

Trunk
Firefox 30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 attachments)

I ran into a strange issue. When you have the bookmarks widget into the menu panel and you click on the borders on top and at the bottom of it the bookmarks panel pop up out of nowhere at the bottom left of the window.
Whiteboard: [Australis:P?]
Whiteboard: [Australis:P?] → [Australis:P4]
Posted image bookmark button.png
Confirmed 29.0a1 (2013-12-15), Win 7 x64
Status: UNCONFIRMED → NEW
Ever confirmed: true
Now it appears attached to the widget but this isn't fixed.
I think it should be more than just a [P4]. It's very disconcerting for the user to have this behaviour in the panel.
Likely a new bug, but I just tested this using the latest Tinderbox build on win7 x64 win32 m-c and after moving the Bookmark Icon to the MenuPanel through Customize, closing the Customize Panel, then opening the MenuPanel and clicking on the Bookmark Star - absolutely nothing happens, no display of bookmarks list or Bookmarks Library..

tested on m-c cset: https://hg.mozilla.org/mozilla-central/rev/d09f9a9f81ae
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #4)
> Likely a new bug, but I just tested this using the latest Tinderbox build on
> win7 x64 win32 m-c and after moving the Bookmark Icon to the MenuPanel
> through Customize, closing the Customize Panel, then opening the MenuPanel
> and clicking on the Bookmark Star - absolutely nothing happens, no display
> of bookmarks list or Bookmarks Library..
> 
> tested on m-c cset: https://hg.mozilla.org/mozilla-central/rev/d09f9a9f81ae

Can confirm yes.
(In reply to Guillaume C. [:ge3k0s] from comment #5)
> (In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #4)
> > Likely a new bug, but I just tested this using the latest Tinderbox build on
> > win7 x64 win32 m-c and after moving the Bookmark Icon to the MenuPanel
> > through Customize, closing the Customize Panel, then opening the MenuPanel
> > and clicking on the Bookmark Star - absolutely nothing happens, no display
> > of bookmarks list or Bookmarks Library..
> > 
> > tested on m-c cset: https://hg.mozilla.org/mozilla-central/rev/d09f9a9f81ae
> 
> Can confirm yes.

This is a different bug. Filed bug 966684.
Whiteboard: [Australis:P4] → [Australis:P3]
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8381325 [details] [diff] [review]
fix Australis bookmarks menu button (literal) edgecase,

Review of attachment 8381325 [details] [diff] [review]:
-----------------------------------------------------------------

This is awful. Well done.
Attachment #8381325 - Flags: review?(bmcbride) → review+
please don't use XXX comments in places code, either a normal comment, or a
// TODO (bug 123456): description
(In reply to Marco Bonardo [:mak] from comment #9)
> please don't use XXX comments in places code, either a normal comment, or a
> // TODO (bug 123456): description

Switched to a normal comment.

remote:   https://hg.mozilla.org/integration/fx-team/rev/6a246a9e1c0c
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/6a246a9e1c0c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
Blocks: 966145
Comment on attachment 8381325 [details] [diff] [review]
fix Australis bookmarks menu button (literal) edgecase,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: In some cases the bookmarks button won't work well when clicked while it's in the panel
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): relatively low
String or IDL/UUID changes made by this patch: none
Attachment #8381325 - Flags: approval-mozilla-aurora?
Attachment #8381325 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: cornel.ionce
I was able to confirm the fix for this bug on the latest Nightly (Build ID: 20140310030201) and Aurora (Build ID: 20140310004003), using:
- Windows 7 64-bit [1],
- Ubuntu 12.04 32-bit [2],
- Mac OS X 10.9.1 [3].

1. Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:30.0) Gecko/20100101 Firefox/30.0
2. Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
3. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.