Closed Bug 946957 Opened 6 years ago Closed 5 years ago

Intermittent testSessionOOMRestore | Page title is correct - got , expected page6

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 37
Tracking Status
firefox35 --- wontfix
firefox36 --- fixed
firefox37 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: mfinkle)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

I'm thinking it's about time to disable these tests until they're more reliable.

https://tbpl.mozilla.org/php/getParsedLog.php?id=31522900&tree=Mozilla-Inbound

Android 4.0 Panda mozilla-inbound opt test robocop-4 on 2013-12-05 13:49:24 PST for push 20e4d6b3c819
slave: panda-0332

14:13:15     INFO -  0 INFO SimpleTest START
14:13:15     INFO -  1 INFO TEST-START | testSessionOOMRestore
14:13:15     INFO -  EventExpecter: no longer listening for Gecko:Ready
14:13:15     INFO -  2 INFO TEST-PASS | testSessionOOMRestore | The correct number of tabs are opened - 3 should equal 3
14:13:15     INFO -  3 INFO TEST-PASS | testSessionOOMRestore | Page title is correct - page3 should equal page3
14:13:15     INFO -  EventExpecter: no longer listening for Content:PageShow
14:13:15     INFO -  4 INFO TEST-PASS | testSessionOOMRestore | Page title is correct - page4 should equal page4
14:13:15     INFO -  EventExpecter: no longer listening for Content:PageShow
14:13:15     INFO -  EventExpecter: no longer listening for Content:PageShow
14:13:15     INFO -  5 INFO TEST-PASS | testSessionOOMRestore | Browser toolbar URL stayed the same - about:home should equal about:home
14:13:15     INFO -  6 INFO TEST-PASS | testSessionOOMRestore | list item at index 2 exists
14:13:15     INFO -  waitForCondition timeout after 4500 ms.
14:13:15     INFO -  7 INFO TEST-UNEXPECTED-FAIL | testSessionOOMRestore | Page title is correct - got , expected page6
14:13:15     INFO -  Exception caught during test!
14:13:15     INFO -  junit.framework.AssertionFailedError: 7 INFO TEST-UNEXPECTED-FAIL | testSessionOOMRestore | Page title is correct - got , expected page6
14:13:15     INFO -  	at junit.framework.Assert.fail(Assert.java:47)
14:13:15     INFO -  	at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:110)
14:13:15     INFO -  	at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:139)
14:13:15     INFO -  	at org.mozilla.gecko.FennecMochitestAssert.is(FennecMochitestAssert.java:145)
14:13:15     INFO -  	at org.mozilla.gecko.tests.BaseTest.verifyPageTitle(BaseTest.java:514)
14:13:15     INFO -  	at org.mozilla.gecko.tests.SessionTest$1$1.onItem(SessionTest.java:209)
14:13:15     INFO -  	at org.mozilla.gecko.tests.SessionTest$1$1.onItem(SessionTest.java:201)
14:13:15     INFO -  	at org.mozilla.gecko.tests.SessionTest$NavigationWalker.walk(SessionTest.java:101)
14:13:15     INFO -  	at org.mozilla.gecko.tests.SessionTest$1.onItem(SessionTest.java:201)
14:13:15     INFO -  	at org.mozilla.gecko.tests.SessionTest$1.onItem(SessionTest.java:189)
14:13:15     INFO -  	at org.mozilla.gecko.tests.SessionTest$NavigationWalker.walk(SessionTest.java:104)
14:13:15     INFO -  	at org.mozilla.gecko.tests.SessionTest.verifySessionTabs(SessionTest.java:189)
14:13:15     INFO -  	at org.mozilla.gecko.tests.testSessionOOMRestore.testSessionOOMRestore(testSessionOOMRestore.java:54)
14:13:15     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
14:13:15     INFO -  	at java.lang.reflect.Method.invoke(Method.java:511)
14:13:15     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
14:13:15     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
14:13:15     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
14:13:15     INFO -  	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:150)
14:13:15     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:127)
14:13:15     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:106)
14:13:15     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:124)
14:13:15     INFO -  	at junit.framework.TestResult.run(TestResult.java:109)
14:13:15     INFO -  	at junit.framework.TestCase.run(TestCase.java:118)
14:13:15     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
14:13:15     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
14:13:15     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:545)
14:13:15     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1551)
14:13:15     INFO -  8 INFO TEST-UNEXPECTED-FAIL | testSessionOOMRestore | Exception caught - junit.framework.AssertionFailedError: 7 INFO TEST-UNEXPECTED-FAIL | testSessionOOMRestore | Page title is correct - got , expected page6
14:13:15     INFO -  9 INFO TEST-END | testSessionOOMRestore | finished in 22051ms
14:13:15     INFO -  10 INFO TEST-START | Shutdown
14:13:15     INFO -  11 INFO Passed: 5
14:13:15  WARNING -  12 INFO Failed: 2
14:13:15  WARNING -  One or more unittests failed.
14:13:15     INFO -  13 INFO Todo: 0
14:13:15     INFO -  14 INFO SimpleTest FINISHED
Flags: needinfo?(bnicholson)
I'd really like to avoid disabling these since session restore is fairly fragile, and session restore bugs can go unnoticed for awhile without these tests in place. I'll look at fixing these soon when I get a chance.
Assignee: nobody → bnicholson
Flags: needinfo?(bnicholson)
(In reply to Brian Nicholson (:bnicholson) from comment #1)
> I'd really like to avoid disabling these since session restore is fairly
> fragile, and session restore bugs can go unnoticed for awhile without these
> tests in place. I'll look at fixing these soon when I get a chance.

This is one of the most common mobile failures now. It also affects Android 4.0 Debug tests and is one of the few remaining factors preventing us from running Android 4.0 Debug robocop tests on trunk trees.

https://tbpl.mozilla.org/?tree=Cedar&jobname=Android.*Debug&rev=cc639242b0a9

:bnicholson -- Are you making any progress?
Flags: needinfo?(bnicholson)
Sorry, this fell off my radar. I'll look into this today, but if I don't find anything, I guess we can just disable it for now.
Flags: needinfo?(bnicholson)
I briefly looked at this and didn't come up with anything, so this patch just disables the test for now.
Attachment #8395531 - Flags: review?(gbrown)
Comment on attachment 8395531 [details] [diff] [review]
Disable testSessionOOMRestore

Review of attachment 8395531 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8395531 - Flags: review?(gbrown) → review+
Whiteboard: [leave open] [test disabled]
This test was re-enabled in bug 979600, marking as dupe.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 979600
Whiteboard: [leave open] [test disabled]
Assignee: bnicholson → michael.l.comella
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Since this is still intermittent after being disabled on Android 2.3 and since I tweaked some code related to this test for different reasons - I thought I'd offer a patch that might help out. 

Try run: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=79d62b29e68c

The patch just uses mSolo directly, but also waits for the View before attempting to use it.
Assignee: michael.l.comella → mark.finkle
Attachment #8545674 - Flags: review?(bnicholson)
Attachment #8545674 - Flags: review?(bnicholson) → review+
I looked a bit more at the FennecNativeDriver and FennecNativeElement code. It uses the Activity directly and spins a sync UI thread. I think moving to the Robocop code directly makes sense whenever we can.

https://hg.mozilla.org/integration/fx-team/rev/a31444b37e97
https://hg.mozilla.org/mozilla-central/rev/a31444b37e97
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
You need to log in before you can comment on or make changes to this bug.