Closed Bug 947162 Opened 6 years ago Closed 2 years ago

Adblock Plus Settings Page locks up the Browser/Add-on Manager

Categories

(Firefox for Android :: Add-on Manager, defect, P5)

26 Branch
ARM
Android
defect

Tracking

()

RESOLVED INVALID
Tracking Status
fennec + ---

People

(Reporter: gcp, Unassigned)

Details

1) Install Firefox Beta from play store (fresh profile is required!)
2) Use Top Sites to go to the add-ons page bookmark
3) Select Most Popular
4) Click AdBlock Plus
5) Click Add To FireFox
6) Approve Installation
7) In the splash screen you get when it finishes, you'll get a page explaining about non-intrusive-addons. Click the link to the settings page in that text.
8) Attempt to use the resulting settings page -> Impossible, checkboxes don't work.
9) Close tab
10) Every screen in Firefox is now white and unusable! What's more, the *thumbnails* in the tabs list DO work correctly.
FWIW I didn't much relevant in logcat, aside from two of these:

D/GeckoLayerClient(12772): Aborting update due to viewport not in display-port
tracking-fennec: --- → ?
Assignee: nobody → wjohnston
tracking-fennec: ? → +
This opens a custom "settings" page using:

Services.ww.openWindow(null, "chrome://adblockplus/content/ui/filters.xul", "_blank", "chrome,centerscreen,resizable,dialog=no", {wrappedJSObject: filter});

Unsurprisingly, it doesn't work. The inline settings in our addon manager do.
Alright, but maybe we can avoid locking up? I mean, something somewhere is hitting this and not allowing Gecko to recover correctly.
Thanks for reporting. Maybe we should override the nsIWindowWatcher in Fennec... That sounds fun and dangerous.
but it would probably be better if the platform just not melt down if two "windows" were open.
I have no plans to work on this and I don't think its a high priority. Unassigning.
Assignee: wjohnston → nobody
Whiteboard: [mentor=wesj]
I filed https://issues.adblockplus.org/ticket/255 on this, opening the filters dialog on Fennec is not the intended Adblock Plus behavior.
https://addons.mozilla.org/en-US/android/addon/adblock-plus/versions/?page=1#version-2.6

AdBlock Plus 2.6 has a number of perf improvements

* Made sure Adblock Plus initialization doesn’t delay Firefox startup.
* Switched to a faster way to access Adblock Plus data on disk.
* Fixed regression in Adblock Plus 2.5.1: Adblock Plus initialization takes longer for each new window opened.

Is this still an issue when using 2.6?
As mentioned above, it isn't a performance issue - it's Adblock Plus trying to open a XUL dialog. The fix for this issue is currently under review, I expect Adblock Plus 2.6.1 release to follow soon (there were several issues affecting Fennec).

Note that the only reason I'm not resolving this as invalid are comments 5 and 6 about solving the underlying issue on the platform level. Other than that the bug is on our end, not in Firefox.
Mentor: wjohnston
Whiteboard: [mentor=wesj]
filter on [mass-p5]
Priority: -- → P5
Mentor: wjohnston2000
With Firefox 57 only WebExtensions are supported and options are HTML pages.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.