Text plugin's link target selector should not be visible unless a URL has been entered

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: kwkofler, Assigned: kwkofler)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Currently, the link target selector is available through UI even when no link address has been entered. It should be hidden until a URL has been entered.
Assignee: nobody → kwkofler
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 1

5 years ago
Created attachment 8344228 [details] [diff] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/372

You were right Scott, that was trickier than I thought it would be, but I think I got a handle on the current design. Any thoughts?
Attachment #8344228 - Flags: review?(scott)
Just a nit, but I noticed there is a comma in "Open Link In:" but none of the other dialogs have a comma. Can probably remove it.
Comment on attachment 8344228 [details] [diff] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/372

Some pull request comments.
Attachment #8344228 - Flags: review?(scott) → review-
(Assignee)

Comment 4

5 years ago
Comment on attachment 8344228 [details] [diff] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/372

Everything should be fixed now
Attachment #8344228 - Flags: review- → review?(scott)
I think at this point, this ticket has merged into bug 947303. Can probably close this one now?
(Assignee)

Comment 6

5 years ago
Originally, I was including these text editor changes in bug 947303 because they had shared functionality in trackevent-editor.js. Not sure why I've still been doing it, but I'd say this is still a distinct issue. I've updated the pull request for this bug with another commit incorporating your feedback on bug 947303, if you'd like to take a look.
I think this served its purpose, but, now that bug 947303 is almost done, and does what we need, I still don't think we have any more use of this ticket.

Am I right to say that once bug 947303 lands, it's going to bring in the changes this ticket has?

Putting the changes from this ticket into bug 947303 was probably the right thing to do.
(Assignee)

Comment 8

5 years ago
Yep, you're right. Should be fine to close, if that's what you want to do. Bug 947303 should be completed, BTW. I addressed Matt's nits and changed the default selector value.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Attachment #8344228 - Flags: review?(scott)
You need to log in before you can comment on or make changes to this bug.