SpecialPowers.snapshotWindow doesn't snapshot zoomed content properly

RESOLVED DUPLICATE of bug 744100

Status

()

Core
Panning and Zooming
RESOLVED DUPLICATE of bug 744100
4 years ago
3 years ago

People

(Reporter: jimm, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [metro])

(Reporter)

Description

4 years ago
Using canvas here in doesn't render the zoomed view when apzc zoom is applied.

http://mxr.mozilla.org/mozilla-central/source/testing/specialpowers/content/specialpowersAPI.js#1187

This will make debugging tests hard, and will probably break other things related to thumbnailing.
(Reporter)

Updated

4 years ago
Version: 26 Branch → Trunk
(Reporter)

Updated

4 years ago
Whiteboard: [metro]
The gfx team has bug 744100 on file for a compositor API to capture what is displayed on-screen. That should be a better solution for this problem.
Depends on: 744100
(Reporter)

Updated

4 years ago
Blocks: 963116
Given the metro use case is no longer being actively pursued and there's already a general purpose gfx bug for this I'm just going to dupe this to that.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
No longer depends on: 744100
Resolution: --- → DUPLICATE
Duplicate of bug: 744100
You need to log in before you can comment on or make changes to this bug.