Closed Bug 947514 Opened 6 years ago Closed 6 years ago

FxOS 1.2: app reload doesn't take changes into account

Categories

(DevTools Graveyard :: WebIDE, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 920481

People

(Reporter: sole, Unassigned)

References

Details

Each time I want to update a packaged app previously installed in the simulator I have to remove the app from the app manager, and from the simulator too, and add it again.

If I don't remove it from the App Manager either it isn't updated or it isn't killed and I can't see the difference. If I knew how to kill an app or if it was automatically killed it would be swell.

If I don't remove it from the simulator, and remove it from the App Manager and install again, I end up with various instances of the same app in the simulator.

I'm using Nightly 2013-12-06 so it's super up to date.
That should not happen. Which version of the Simulator do you use?
1.2 - the only one I can find?
And *App Manager*
Flags: needinfo?(paul)
Soledad, what version of the Simulator do you see in the add-on manager?  For example, I have "Firefox OS 1.2 Simulator 6.0pre6.20131125".
Flags: needinfo?(sole)
I have that one too.
Flags: needinfo?(sole)
I can reproduce this here, on 1.2.

Soledad, until we fix that, you can kill your app with a long press on the home button.
Flags: needinfo?(paul)
Summary: Need to remove and re-add app for it to be actually updated → FxOS 1.2: app reload doesn't take changes into account
Soledad, can you confirm that it works for you with Firefox OS 1.3: https://ftp.mozilla.org/pub/mozilla.org/labs/fxos-simulator/
Flags: needinfo?(sole)
So this happens because we didn't uplift attachment 821060 [details] [diff] [review] from bug 920481 to Gecko 26. I'll see if it's something we can add to Firefox OS 1.2.
Depends on: 920481
Yep, it WORKS with the Firefox OS 1.3 simulator.

Hopefully it can be backported to 1.2 :D
Flags: needinfo?(sole)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920481
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.