"this.updateProviderURLs is not a function" when toggling "Block reported attack sites" preference

RESOLVED FIXED in Firefox 27

Status

()

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

Trunk
Firefox 29
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox25 wontfix, firefox26- wontfix, firefox27- fixed, firefox28- fixed, firefox29 fixed)

Details

(Whiteboard: verifyme)

Attachments

(1 attachment)

When you go into the preference dialog and toggle "Block reported attack sites" an error is thrown saying that "this.updateProviderURLs is not a function". I believe that calling addObserver(this.readPrefs) doesn't pass the right scope. We should probably also have a small test that toggles the preference.
This is broken since Fx 19 it seems and it's probably too late to get this into beta now.
Attachment #8344149 - Flags: review?(gavin.sharp)
Yes, it's not something we'd chemspill for, nor include in a dot release - we can get this uplifted if low risk to Aurora/Beta and get bake time there.
We do not need to track this please nominate if low risk uplift.
Comment on attachment 8344149 [details] [diff] [review]
0001-Bug-947583-Fix-this.updateProviderURLs-is-not-a-func.patch

blech.
Attachment #8344149 - Flags: review?(gavin.sharp)
Attachment #8344149 - Flags: review?(dolske)
Attachment #8344149 - Flags: review+
https://hg.mozilla.org/integration/fx-team/rev/f76968cb56d6
Assignee: nobody → ttaubert
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/f76968cb56d6
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Comment on attachment 8344149 [details] [diff] [review]
0001-Bug-947583-Fix-this.updateProviderURLs-is-not-a-func.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 778608
User impact if declined: Changes to "Block reported attack sites" and "Block reported web forgeries" checkboxes in the pref dialog won't take effect until a browser restart.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Very low-risk, one line patch.
String or IDL/UUID changes made by this patch: None.
Attachment #8344149 - Flags: approval-mozilla-beta?
Attachment #8344149 - Flags: approval-mozilla-aurora?
Attachment #8344149 - Flags: approval-mozilla-beta?
Attachment #8344149 - Flags: approval-mozilla-beta+
Attachment #8344149 - Flags: approval-mozilla-aurora?
Attachment #8344149 - Flags: approval-mozilla-aurora+
Tim, does this have or need tests?
Flags: needinfo?(ttaubert)
Flags: in-testsuite?
No, this doesn't have a test. It could have one though.
Flags: needinfo?(ttaubert)
Whiteboard: verifyme
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.