Firefox SNI error on idle

RESOLVED DUPLICATE of bug 728715

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 728715
5 years ago
5 years ago

People

(Reporter: Christian Hügel, Unassigned)

Tracking

25 Branch
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131209])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Linux; Android 4.2.2; Gigaset QV1030 Build/JDQ39) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.59 Safari/537.36

Steps to reproduce:

I have a Apache 2.2 openssl 1.x server with SNI support enabled. This works with about 6 SSL sites without a problem


Actual results:

Now when I access the site with Firefox 25 the certificate is valid as expected. But when I idle a couple of minutes on the site and try to open a page on that site, FF tells me something is wrong with the certificate. If I take a closer at the error message, I can see that the certificate is correct. So why is FF reporting a wrong certificate if the certificate is correct?


Expected results:

FF should not have a problem with sni on a SSL site when idle. I have tested this with chrome and IE and none showed the issue reported above.
(Reporter)

Updated

5 years ago
Summary: Firefox SNI error in idle → Firefox SNI error on idle
(Reporter)

Comment 1

5 years ago
I fugured this out. This had to do with the SSLSessionCache directive in apache. Here's more info about it:
https://issues.apache.org/bugzilla/show_bug.cgi?id=52703
https://bugzilla.mozilla.org/show_bug.cgi?id=728715

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [bugday-20131209]
Duplicate of bug: 728715
You need to log in before you can comment on or make changes to this bug.