Closed Bug 947603 Opened 6 years ago Closed 6 years ago

IonMonkey: preparation for optimization levels

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla28

People

(Reporter: h4writer, Assigned: h4writer)

References

Details

(Whiteboard: [qa-])

We want to land part3 of optimization levels already. Since this could improve some edge-cases. But we are not sure we can land everything in time for merge on Monday and be sure we have no regressions or backouts. It would be hard to maintain a bug across versions. So here we will land the preparation patches part1-3 (in FF28). And the rest will land in FF29.
Blocks: 939614
https://hg.mozilla.org/mozilla-central/rev/0443d213ad79
https://hg.mozilla.org/mozilla-central/rev/03916ed4ced2
https://hg.mozilla.org/mozilla-central/rev/e809fabe13e3
Assignee: nobody → hv1989
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.