bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Make OS_TARGET=WIN95 the default on Windows

RESOLVED FIXED in 3.15.4

Status

NSS
Build
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: briansmith, Assigned: briansmith)

Tracking

trunk
3.15.4
All
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 2 obsolete attachments)

Created attachment 8344241 [details] [diff] [review]
default-OS_TARGET_WIN95-on-Windows.patch

Whenever I tell somebody how to build NSS, I have to give them two sets of instructions: "make nss_build_all", or "OS_TARGET=WIN95 make nss_build_all" on Windows. Also, we've seen people getting confused about OS_TARGET=WINNT vs OS_TARGET=WIN95 and also, AFAICT, we consider OS_TARGET=WINNT deprecated or close to deprecated.

This patch makes OS_TARGET=WIN95 when OS_ARCH=WINNT when OS_TARGET isn't explicitly defined.
Attachment #8344241 - Flags: review?(wtc)
Can we just make NSS's build system smart enough to figure out which system it's on in the absence of OS_TARGET? (Or is that basically what this does?)
(In reply to David Keeler (:keeler) from comment #1)
> Can we just make NSS's build system smart enough to figure out which system
> it's on in the absence of OS_TARGET? (Or is that basically what this does?)

This is what the patch does. Windows is an exception because the default, WINNT, is not the one most people want.

Comment 3

5 years ago
Is this a subset or dupe of Bug 814982?

Comment 4

5 years ago
Comment on attachment 8344241 [details] [diff] [review]
default-OS_TARGET_WIN95-on-Windows.patch

Review of attachment 8344241 [details] [diff] [review]:
-----------------------------------------------------------------

r=wtc.

::: coreconf/arch.mk
@@ +150,5 @@
>  #
>  
>  #
>  # The following hack allows one to build on a WIN95 machine (as if
>  # s/he were cross-compiling on a WINNT host for a WIN95 target).

We should also remove this block of code. We don't build on
Win9x machines any more. I can write a patch.
Attachment #8344241 - Flags: review?(wtc) → review+

Comment 5

5 years ago
Created attachment 8346966 [details] [diff] [review]
Remove support for building on Win9x machines
Attachment #8346966 - Flags: review?(brian)

Comment 6

5 years ago
Comment on attachment 8344241 [details] [diff] [review]
default-OS_TARGET_WIN95-on-Windows.patch

Review of attachment 8344241 [details] [diff] [review]:
-----------------------------------------------------------------

::: coreconf/arch.mk
@@ +230,5 @@
>  	endif
>      endif
>  endif
>  #
> +# If uname -s returns "MINGW32_NT-*", we assume that we are using

A few lines above, there is a comment that says
  # If uname -s returns "MINGW32_NT-5.1", we assume that we are using

It should be fixed in the same way.
Attachment #8346966 - Flags: review?(brian) → review+
Comment on attachment 8344241 [details] [diff] [review]
default-OS_TARGET_WIN95-on-Windows.patch

Review of attachment 8344241 [details] [diff] [review]:
-----------------------------------------------------------------

::: coreconf/arch.mk
@@ +230,5 @@
>  	endif
>      endif
>  endif
>  #
> +# If uname -s returns "MINGW32_NT-*", we assume that we are using

I guess you meant this:

# If uname -s returns "CYGWIN_NT-*", we assume that we are using
# the uname.exe in the Cygwin tools.

I made the change.
Created attachment 8347099 [details] [diff] [review]
Part 1: Make OS_TARGET=WIN95 the default on Windows
Attachment #8344241 - Attachment is obsolete: true
Attachment #8347099 - Flags: review+
Created attachment 8347100 [details] [diff] [review]
Part 2: Remove support for building on Win9x machines
Attachment #8346966 - Attachment is obsolete: true
Attachment #8347100 - Flags: review+
http://hg.mozilla.org/projects/nss/rev/6593411d388b
http://hg.mozilla.org/projects/nss/rev/ccaf2d1690fc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 11

5 years ago
Comment on attachment 8344241 [details] [diff] [review]
default-OS_TARGET_WIN95-on-Windows.patch

Review of attachment 8344241 [details] [diff] [review]:
-----------------------------------------------------------------

::: coreconf/arch.mk
@@ +230,5 @@
>  	endif
>      endif
>  endif
>  #
> +# If uname -s returns "MINGW32_NT-*", we assume that we are using

Yes, you are right. Sorry about the copy-and-paste error.
Backed out for Windows test failures:
http://hg.mozilla.org/projects/nss/rev/299a8e8c904a
http://hg.mozilla.org/projects/nss/rev/49360b638350
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 8347888 [details]
Log of build failure #1: 3-win7-x64-DBG.txt
Created attachment 8347889 [details]
Log of build failure #2: 3-winxp-x64-DBG.txt
Created attachment 8347890 [details]
Log of build failure #3: 3-winxp-x64-OPT.txt

Comment 16

5 years ago
Comment on attachment 8347100 [details] [diff] [review]
Part 2: Remove support for building on Win9x machines

This patch doesn't need to be backed out. I checked it in again:
https://hg.mozilla.org/projects/nss/rev/89704a8628e9
Attachment #8347100 - Flags: checked-in+
Comment on attachment 8347099 [details] [diff] [review]
Part 1: Make OS_TARGET=WIN95 the default on Windows

(In reply to Wan-Teh Chang from comment #16)
> Comment on attachment 8347100 [details] [diff] [review]
> Part 2: Remove support for building on Win9x machines
> 
> This patch doesn't need to be backed out. I checked it in again:
> https://hg.mozilla.org/projects/nss/rev/89704a8628e9

Neither patch needed to be backed out. Since you checked in the second one again, I just checked in the first one, so that the two patches for this bug are not split between two different releases:

http://hg.mozilla.org/projects/nss/rev/5f4ba3533468
Attachment #8347099 - Flags: checked-in+
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.