mozilla 0.93 does not start after installation

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Igor Furlan, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
MOZ 0.93 does not start after installation.

I downloaded the file from here:
http://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.3/mozilla-i686-pc-linux-gnu-0.9.3-installer.tar.gz

and installed it using the "./mozilla-installer"

After the installation mozilla started automaticaly and
produced the following output:

[tina@tina try]$ ./mozilla
./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/try
  LD_LIBRARY_PATH=/usr/local/try:/usr/local/try/plugins:/usr/local/lib
     LIBRARY_PATH=/usr/local/try:/usr/local/try/components
       SHLIB_PATH=/usr/local/try
          LIBPATH=/usr/local/try
       ADDON_PATH=/usr/local/try
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
 I am inside the initialize
 Hey : You are in QFA Startup 
(QFA)Talkback error: Can't initialize.

------------------------------

That was it... no browser on my screen

I am curently using
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628

which craches 1-2 times in 2-3 hours of constant usage.. only browsing
the net
(Reporter)

Comment 1

17 years ago
My second attempt was to download the whole package from here
http://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.3/mozilla-i686-pc-linux-gnu-0.9.3-sea.tar.gz

and YESSSS...  after I dowloaded the complete package, I was able
to start moz0.93.  Please see the screen output, which fllows.
You can see that the script complains about "current directory"..
but it seems that it is not important....  mozilla 0.93 starts !!
And this is important !!!



[root@tina mozilla-installer]# shell-init: could not get current directory
job-working-directory: could not get current directory
/usr/local/mozila_0.93/run-mozilla.sh /usr/local/mozila_0.93/mozilla-bin -installer
shell-init: could not get current directory
job-working-directory: could not get current directory
job-working-directory: could not get current directory
MOZILLA_FIVE_HOME=/usr/local/mozila_0.93
  LD_LIBRARY_PATH=/usr/local/mozila_0.93:/usr/local/mozila_0.93/plugins:.:
     LIBRARY_PATH=/usr/local/mozila_0.93:/usr/local/mozila_0.93/components
       SHLIB_PATH=/usr/local/mozila_0.93
          LIBPATH=/usr/local/mozila_0.93
       ADDON_PATH=/usr/local/mozila_0.93
      MOZ_PROGRAM=/usr/local/mozila_0.93/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
job-working-directory: could not get current directory
job-working-directory: could not get current directory
*** QfaServices is being registered
>>>>>>>>>>>> chatzilla-service loaded*** Registering -chat handler.
*** Registering x-application-irc handler.
*** Registering irc protocol handler.
 I am inside the initialize
 Hey : You are in QFA Startup 
(QFA)Talkback loaded Ok.
Reporter:

Have you installed the first build over an older build and
then you installed the second time in a fresh directory ?
Assignee: asa → ssu
Component: Browser-General → Installer
QA Contact: doronr → gemal
(Reporter)

Comment 3

17 years ago
nope ...  both builds were fresh builds...  that is the main reason
why I  have two directories , "try" and "mozilla_0.93"
I did not want to install second build on top of the "try" build
From the repoter's earlier comments:

The first install (try) failed while on user tina (not root).
The second install (mozilla_0.93) suceeds on user root.

This is then a dupe of bug 42184.  Please read that bug for a few workarounds.

(from the release notes) If you are installing Mozilla on a multi-user operating
system such as Linux, Unix, or Windows 2000, you should install it separately in
the user directory of each user who plans to use Mozilla . (Bug 42184) If you
install Mozilla in a shared write-protected directory, it may not run properly.
(Bug 42184)


*** This bug has been marked as a duplicate of 42184 ***
URL: none
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: gemal → gbush
(Reporter)

Comment 5

17 years ago
Nope.. I think that your conclusion is not correct. Here is why:
In both cases I have installed mozilla as "root"..  otherwise I
could not install it in "/usr/local". Yes, mozilla (from "try" directory)
started automaticaly after installation and produced exactly the same
result as couple minutes later when I have tried to start it as regular user
(tina). "try" installation was done with the file
....../mozilla-i686-pc-linux-gnu-0.9.3-installer.tar.gz

The working installation into directory "mozilla_0.93" was done with
the file ..../mozilla-i686-pc-linux-gnu-0.9.3-sea.tar.gz
I can run it as "root" or regular user "tina". IT WORKS in both cases.

In both cases I installed mozilla in the directory "/usr/local"..  therefore
I was in both cases "root" during installation. 
In first case (try) I am not able to run mozilla as regular user tina
or as root.

So, I consider this a BUG  and not as duplicate of some other bug.




Comment 6

16 years ago
Igor,

I tried to reproduce this bug using your scenarios.
1. install using stub installer as root (which failed for  you both as root and 
tina)  last console message is talkback  Can't initialize

2. install using tarball as root (and you were successful both as root and tina)

Alas, I was successful in launching in both cases - no talkback error noted- it 
loaded ok.  
I am wondering if the problem is not the installer or user (root/tina) but the 
package itself did not get installed. 
Can you try 0.9.4 or a recent nightly please and see if it recurs?

reopening- not sure it is dupe of 42184
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

16 years ago
This bug is about 0.9.3, we are close to 0.9.6, nobody can confirm the problem
---> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.