Calendars on decko.ceskatelevize.cz require Flash version 11.4, Linux-based browsers only have < 11.2.x

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: mkyral, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-cz][jsissue][contactready], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8344400 [details]
JS exception

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131124082804

Steps to reproduce:

When I open an URL: http://decko.ceskatelevize.cz/advent in FF 25 on linux, it does not work. It should be interactive, but only a static image is shown. 


Actual results:

An image is shown, but is not clickable.


Expected results:

Image is fully interactive.

The page is a mix of Javascript and flash. I've tried the js debugger and it shows me an exception in attachment. I've tried safe-mode, a new profile, official binary Firefox from mozilla site (I'm using Gentoo linux). I tested two my Linux boxes, It is still the same. It looks like a bug in the page. 

But it works in Chrome and it works on latest FF on Windows. Also I have confirmed that id does not work with latest FF on Ubuntu. ( http://forum.mozilla.cz/viewtopic.php?f=3&t=10900 ) 

So it looks like a Linux FF bug. Or it is a bug in page, even it works in FF on Windows?

My system: Gentoo Linux, kernel 3.12, KDE 4.11, nvidia-drivers 331.20, Firefix-25.0.1 Firefox-bin-25.0
(Reporter)

Updated

5 years ago
Can this be tested even if it's no longer early December?
Flags: needinfo?(mkyral)
I suppose this Easter calendar is equivalent: http://decko.ceskatelevize.cz/velikonoce

So the main implementation is in Flash.

http://decko.ceskatelevize.cz/cms/hry/js/flash-app.js?v=1

// kontrola flash playeru
function hasFlash() {
	var hasFlash = false;
	try {
		var fo = new ActiveXObject('ShockwaveFlash.ShockwaveFlash');
		if (fo) {
			hasFlash = true;
		}
	} catch (e) {
		if (navigator.mimeTypes ["application/x-shockwave-flash"] != undefined) {
			hasFlash = true;
		}
	}
	return hasFlash;
}

So far so good - this Flash detection is sensible and should not cause any problems.
(Reporter)

Comment 3

5 years ago
Yes, the Easter calendar is equal and will be available till end of April. Then again in December.
Flags: needinfo?(mkyral)
The JSON data from the server includes a property "playerVersion: 11.4" and this is passed to SWFObject as the earliest supported Flash version. This won't work on Linux because the latest Flash player version (at the time of writing) available is 11.2.202.

The Flash stuff seemed to work just fine in 11.2 on Ubuntu, so we should recommend that they allow earlier versions.

(Just for the record: the error message in the summary is typically caused by some feature testing in jQuery, it's harmless).
Status: UNCONFIRMED → NEW
Component: Untriaged → Desktop
Ever confirmed: true
Product: Firefox → Tech Evangelism
Summary: DOMException "An invalid or illegal string was specified" on linux (http://decko.ceskatelevize.cz/advent) → Calendars on decko.ceskatelevize.cz require Flash version 11.4, Linux-based browsers only have < 11.2.x
Whiteboard: [country-cz][jsissue][contactready]
Version: 25 Branch → Trunk
The new calendar does not require Flash anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.