Closed Bug 947780 Opened 6 years ago Closed 6 years ago

Google Drive sends fennec into a infinite redirect loop upon sign-in

Categories

(Web Compatibility :: Mobile, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: wesj, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: reproducible, Whiteboard: [serversniff] [country-all] )

We should block infinite loops like this, but it would be nice if evang could try talk to google about fixing it.
Works for me tonight; retry tomorrow?
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Summary: docs.google.com sends fennec into a infinite redirect loop → Google Drive sends fennec into a infinite redirect loop
Is drive.google.com the same as docs.google.com?
As of 2012, docs.google.com redirects to drive.google.com
Duplicate of this bug: 947962
I had to sign-in, whoops. Yes, reproducible today.
Keywords: reproducible
Summary: Google Drive sends fennec into a infinite redirect loop → Google Drive sends fennec into a infinite redirect loop upon sign-in
In nightly here's what I see: (-> means redirect)

1) drive.google.com
JS-> https://accounts.google.com (sign in)
-> https://drive.google.com

WFM.

Sign out.

1) docs.google.com
JS-> www.google.com/accounts/ServiceLogin
302-> accounts.google.com (sign in, choose account if you have multiple) 
(A few GETs and POSTs to accounts youtube.com (what?) and accounts.google.com)
meta-> docs.google.com/m (from accounts.youtube.com)
JS-> www.google.com/account/ServiceLoginAuth, check a cookie, once more talk to youtube.com
302-> accounts.google.com...&continue=docs.google.com/m/...
meta->http://docs.google.com/m
JS-> www.google.com/accounts/ServiceLogin

Ad infinitum.

Chrome Mobile (emulated) has basically the same story, except when it finally lands on docs.google.com/m, it gets a JS redirect to drive.google.com.

1) docs.google.com
JS-> www.google.com/accounts/ServiceLogin
302-> accounts.google.com (sign in, choose account if you have multiple) 
(A few GETs and POSTs to accounts youtube.com (what?) and accounts.google.com)
meta-> docs.google.com/m (from accounts.youtube.com)
JS-> www.google.com/account/ServiceLoginAuth, check a cookie, once more talk to youtube.com
302-> accounts.google.com...&continue=docs.google.com/m/...
meta->http://docs.google.com/m
JS -> drive.google.com/m
200 OK. The page sticks.

So. For some reason docs.google.com/m doesn't think Firefox for Android is ever signed in, so it bounces it back to www.google.com/accounts/ServiceLogin.

However, when I spoof my UA string to be the native Android browser, the same thing happens. Core bug? Regression?
Assignee: miket → nobody
I just noticed this reproduces in Desktop too, as long as you spoof your UA string as anything Mobile (Fennec, Chrome Mobile, Android, iPhone).
Whiteboard: [serversniff] [country-all]
Tried logging in today (Firefox for Android) and this works for me.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.