Navigation toolbar graphics glitches in Australis with Direct2D enabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: jkitch, Unassigned)

Tracking

(Blocks: 1 bug)

28 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Austalis:P-])

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 8344463 [details]
screenshot of duplicated line

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131208030204

Steps to reproduce:

Open a window in an Australis build and press the new tab button.

(Tested in both latest nightly and a self-compiled build based on latest mozilla-central)


Actual results:

The line in the middle of bookmark button (between the star/list icons) is duplicated (see duplicated attachment).  When moving the mouse over the bookmark button, the additional line disappears, however the line now appears to have a gap in it (see gap attachment).  

The bug doesn't always occur.  It may be necessary to close the created tabs and and repeat the process.




Expected results:

No graphics glitch should occur
(Reporter)

Comment 1

5 years ago
Created attachment 8344464 [details]
screenshot of line with gap
(Reporter)

Comment 2

5 years ago
Graphics information from about:support

Graphics
Adapter Description	Intel(R) G41 Express Chipset
Adapter Drivers	igdumd64 igd10umd64 igdumdx32 igd10umd32
Adapter RAM	Unknown
Device ID	0x2e32
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	10-4-2012
Driver Version	8.15.10.2869
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) G41 Express Chipset Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

I am unable to replicate it with Direct2D disabled.
Blocks: 939862
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 3

5 years ago
Created attachment 8348524 [details]
devtools.png

1. Move "Developer Tools" button to navigation toolbar
2. Click "Developer Tools" button
3. Click "Toggle Tools"

The graphics glitch should (but not always) appear.  It only manifests itself when toggling the tools from hidden to visible.

Once again, I am unable to replicate this behaviour with Direct2D disabled.
(Reporter)

Updated

5 years ago
Summary: Bookmark button graphics glitch in Australis → Navigation toolbar graphics glitches in Australis with Direct2D enabled
James, can you still reproduce this issue?
Flags: needinfo?(jkitch.bug)
(Reporter)

Comment 5

5 years ago
Created attachment 8364105 [details]
currently.png

After testing with latest nightly:

* No vertical lines appear between the  bookmarks buttons most of the time.  (Very rarely a single line appears).
* Most of the time there is a small mark between and below the two buttons (you may need to zoom in to see it). It seems to be the same mark that appears in the "line with gap" screenshot (attachment 8344464 [details])
* Devtools button corruption still occurs.
Flags: needinfo?(jkitch.bug)
(Reporter)

Comment 6

5 years ago
Update:  After testing with the latest nightly, the appearance of multiple lines (as shown in attachment 8344463 [details]) has returned.
Duplicate of this bug: 962955
Bas: is this your area? Likely to be a graphics driver bug (blacklist it?), or something on our end?
Flags: needinfo?(bas)
Untracking from Australis as it doesn't appear to be a common issue.
Whiteboard: [Austalis:P-]
I don't believe this is still occurring.
Flags: needinfo?(bas)
(Reporter)

Comment 11

4 years ago
That is probably the case.

I no longer have ready access to the computer which suffered from this problem, but I don't recall triggering this bug when I used it in the last few months.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.