Border style is rendered NOT correctly when dotted and border-radius set

RESOLVED DUPLICATE of bug 382721

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 382721
4 years ago
4 years ago

People

(Reporter: Chen Zhixiang, Unassigned)

Tracking

(Blocks: 1 bug)

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8344522 [details]
index.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.57 Safari/537.36

Steps to reproduce:

<body>
<style>
div{
  width:400px;
  height:200px;
  border: 10px dotted blue;
  border-radius: 11px;
}
</style>
<div />
</body>



Actual results:

The "Dot" is rendered as a circle, but it should be square.


Expected results:

The "Dot" is rendered as a circle, but it should be square.
(Reporter)

Updated

4 years ago
Summary: Border style is rendered NOT correctly when dotted and "border-radius > border-width" → Border style is rendered NOT correctly when dotted and border-radius set
(Reporter)

Comment 1

4 years ago
We are developing based on QtWebKit, we have 3 main platform to compare:

1, Qt-4.8 -5.0 WebKit
2, Chrome 31
3, Firefox 25

So, the basic conclusions are:
1, QtWebKit can NOT render ```dotted``` border when border-radius is larger than border-width;
2, Chrome 31 seems to render perfectly good
3, Firefox 25 can render ```dotted``` style no matter the widths of border-radius and border-width, but the corner case is NOT very correct, and the border dot is circle(should be square)

Updated

4 years ago
Blocks: 431176
Component: Untriaged → Layout
Product: Firefox → Core

Comment 2

4 years ago
Maybe a dupe.
Whiteboard: DUPEME?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382721
You need to log in before you can comment on or make changes to this bug.