If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

YouTube HTML5 player does not offer full-screen toggle for embedded YouTube video for Firefox for Android

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: matt hunkel, Assigned: wesj)

Tracking

Trunk
All
Android
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(fennec+)

Details

(Whiteboard: [video], URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20121017 Firefox/16.0 (Nightly/Aurora)
Build ID: 20121017032616

Steps to reproduce:

Using Firefox on a Samsung Galaxy Note 3 watching a page with embedded youtube videos.


Actual results:

There is no possibility to fullscreen the youtube video.


Expected results:

There should be a toggle to switch in fullscreen like it is in the original browser or chrome.
(Reporter)

Updated

4 years ago
OS: Windows 7 → Android
Hardware: x86_64 → All
The native HTML5 player is served to us from Google and they do not serve up the same player to us with a small full-screen button on their control-row.

Test-case: http://jsfiddle.net/7K8Ew/1/

Chrome: You'll see a full-screen control on their control-row in the embedded player
Firefox for Android: The full-screen control is missing

This will need investigation into which component of their video detection script is failing. We support full-screen playback: http://people.mozilla.org/~atrain/mobile/tests/media.html, long tap on a video and select full-screen.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: embedded youtube videos doesnt offer fullscreen toggle → YouTube HTML5 player does not offer full-screen toggle for embedded YouTube video for Firefox for Android

Updated

4 years ago
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 25 → Trunk

Updated

4 years ago
Blocks: 668288
Not sure if this qualifies for the [video] whiteboard. Please remove if not.
Whiteboard: [video]
Seems this is simply a dup of bug 790126 - YouTube relies on native <video> controls, and Firefox on Android doesn't have a fullscreen button there..
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 790126

Updated

3 years ago
Duplicate of this bug: 1008655
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Component: Mobile → General
Product: Tech Evangelism → Firefox for Android
Status: REOPENED → NEW
Re-opening and nominating based on triage discussions of bug 704229
tracking-fennec: --- → ?

Updated

3 years ago
No longer blocks: 668288
Wes - Let's revisit this particular bug without worrying about unifying all the code.
Assignee: nobody → wjohnston
tracking-fennec: ? → +
(Assignee)

Comment 7

3 years ago
Work for this is happening in bug 1018468.
Depends on: 1018468
(Assignee)

Comment 8

3 years ago
Bug 1018468 fixed this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
Flags: qe-verify+

Updated

3 years ago
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.