Closed Bug 947906 Opened 6 years ago Closed 6 years ago

Personas Plus's preview issue in Australis

Categories

(Firefox :: Extension Compatibility, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: pauly, Unassigned)

References

Details

(Keywords: addon-compat, Whiteboard: [Australis:P-])

Nightly 28.0a1 (2013-12-08), Win 7 x64
STR:
1. Install Personas Plus addon
2. Click on the widget in the nav-bar and select 'Default'
3. Go to 'Featured' and try to hover with mouse more personas

Expected results:
Personas should preview in Firefox on hovering

Actual results:
Menu closes after a short preview of the selected personas

Works fine on Holly 28.0a1 (2013-12-08), where the widget is in the add-on bar.
Blocks: australis-addons
No longer blocks: australis-cust, 749804
Keywords: addon-compat
This works for me.
Paul, can you still reproduce, as Kris says this is working (now)?
Flags: needinfo?(paul.silaghi)
Yes.
http://screencast.com/t/YzepF5p6VU
Flags: needinfo?(paul.silaghi)
I still can't reproduce this on the latest nightly, Windows or Linux.
Paul, can you check the browser console for warnings/errors related to themes/personas?
Flags: needinfo?(paul.silaghi)
A promise chain failed to handle a rejection.
Date: Wed Feb 05 2014 11:38:28 GMT+0200 (GTB Standard Time)
Full Message: Win error 3 during operation remove (The system cannot find the path specified

1391593118449	Services.HealthReport.HealthReporter	WARN	Saved state file does not exist.
1391593118449	Services.HealthReport.HealthReporter	WARN	No prefs data found.

Expected color but found '#None'.  Error in parsing value for 'background-color'.  Declaration dropped.

Nothing conclusive I guess...
Flags: needinfo?(paul.silaghi)
I also can't reproduce this.

Seems unlikely that this would be due to Australis, since Australis changes wouldn't seem to be involved with LWT change or hovering over a menu.

If this is reliably reproducible it might be possible to find a regression range on older UX builds?
Whiteboard: [Australis:P4-]
(In reply to Justin Dolske [:Dolske] from comment #7)
> If this is reliably reproducible it might be possible to find a regression
> range on older UX builds?
GOOD: UX 2013-06-25 - the add-on bar still exists
BAD: UX 2013-06-27 - the add-on bar is gone
I can't find the UX 2013-06-26 build, but I would say this regressed once with the add-on bar removal - bug 749804
Have you tried this with a clean profile?
Whiteboard: [Australis:P4-] → [Australis:P-]
(In reply to Kris Maglione [:kmag] from comment #9)
> Have you tried this with a clean profile?
Yes. Make sure you're selecting the default state before trying to reproduce (step 2, comment 0)
I did. I followed the steps in comment 0 exactly, but with a fresh profile or without, preview still works flawlessly on Firefox 29.
WFM as well. There might be a step missing to be able to reproduce this reliably.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.