Closed Bug 948000 Opened 6 years ago Closed 5 years ago

Scriptability of anonymous content should not depend on the scriptability of the bound content

Categories

(Core :: XBL, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 986730

People

(Reporter: bholley, Unassigned)

References

Details

I tried to write test coverage for this in bug 944407, but it broke. I then realized that we should probably just wait until anonymous content reflectors are fully moved to the XBL scope in bug 825392.

I'm adding a todo for this in content/xbl/test/file_bug944407.xml, which we can flip when everything is sorted out here.
I just realized that doing this requires hoisting _all_ anonymous content into the XBL scope, not just ChromeOnlyAccess().

Boris, what do you think about doing that? Now that we don't expose document.getAnonymous* to content anymore (bug 912322), there should be no way for content to get at these nodes, right?
Flags: needinfo?(bzbarsky)
What anonymous content is there that is not ChromeOnlyAccess() _and_ not already in the XBL scope?
Flags: needinfo?(bzbarsky)
(In reply to Boris Zbarsky [:bz] from comment #2)
> What anonymous content is there that is not ChromeOnlyAccess() _and_ not
> already in the XBL scope?

Anything that is not either marked as _native_ anonymous content (by layout), marked as chromeOnlyContent (by markup), or descended from either of the above. A standard piece of anonymous content is neither of those things.
So by "standard anonymous content" you mean XBL-bound anonymous content?

I have no problem with putting that in the XBL scope.

On the other hand, shadow DOM anonymous content should NOT go in the XBL scope, right?  Not least because there are in fact DOM methods for getting at it.
(In reply to Boris Zbarsky [:bz] from comment #4)
> On the other hand, shadow DOM anonymous content should NOT go in the XBL
> scope, right?  Not least because there are in fact DOM methods for getting
> at it.

Agreed. It looks like shadow DOM stuff uses NODE_IS_IN_SHADOW_TREE, rather than NODE_IS_IN_ANONYMOUS_SUBTREE, so we shouldn't be in any danger of confusing the two. William, is that correct?
(In reply to Bobby Holley (:bholley) from comment #5)
> Agreed. It looks like shadow DOM stuff uses NODE_IS_IN_SHADOW_TREE, rather
> than NODE_IS_IN_ANONYMOUS_SUBTREE, so we shouldn't be in any danger of
> confusing the two. William, is that correct?

That's correct, Shadow DOM doesn't use NODE_IS_IN_ANONYMOUS_SUBTREE, these flags are orthogonal.
Depends on: 986730
This was fixed by bug 986730, and the test coverage was enabled.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 986730
You need to log in before you can comment on or make changes to this bug.