Closed Bug 948009 Opened 6 years ago Closed 6 years ago

Record length of time spent with customize dialog open.

Categories

(Firefox :: Toolbars and Customization, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Future
Tracking Status
firefox27 --- fixed
firefox28 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

Details

(Whiteboard: [Non-Australis-Only][qa-])

Attachments

(1 file, 1 obsolete file)

We want UITelemetry on how long the customization dialog is open for.
This can be skewed really badly if someone leaves it open and walks away from their machine. Should we only track time during mousemove events?
(In reply to Jared Wein [:jaws] from comment #1)
> This can be skewed really badly if someone leaves it open and walks away
> from their machine. Should we only track time during mousemove events?

While this is true, after talking with bwinton, we're thinking that these events are rare enough that we can cull them as outliers.
Attached patch Patch v1.1Splinter Review
Attachment #8346125 - Attachment is obsolete: true
Comment on attachment 8346126 [details] [diff] [review]
Patch v1.1

Review of attachment 8346126 [details] [diff] [review]:
-----------------------------------------------------------------

Please make sure to put "[Holly]" in the commit message.

::: browser/modules/BrowserUITelemetry.jsm
@@ +223,5 @@
>  
> +// Weakly maps browser windows to objects whose keys are relative
> +// timestamps for when some kind of session started. For example,
> +// when a customization session started. That way, when the window
> +// exists customization mode, we can determine how long the session

s/exists/exits/

@@ +452,5 @@
>  
> +  startCustomizing: function(aWindow) {
> +    this.countCustomizationEvent("start");
> +    let durationMap = WINDOW_DURATION_MAP.get(aWindow);
> +    durationMap.customization = Date.now();

Please use aWindow.performance.now() instead (here and below) as Date.now() is not guaranteed to be monotonically increasing.
Attachment #8346126 - Flags: review?(jaws) → review+
Done! As usual, fantastic reviewing time.

Landed on Holly as https://hg.mozilla.org/projects/holly/rev/3f0c7e1df6d6
Status: NEW → ASSIGNED
Comment on attachment 8346126 [details] [diff] [review]
Patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

None. This gives BrowserUITelemetry the ability to record durations spent with the customization dialog open.


User impact if declined: 

None.


Testing completed (on m-c, etc.): 

Just manual testing.


Risk to taking this patch (and alternatives if risky): 

Very low.


String or IDL/UUID changes made by this patch:

None.
Attachment #8346126 - Flags: approval-mozilla-beta?
Attachment #8346126 - Flags: approval-mozilla-aurora?
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Removing Australis:P1 whiteboard tag because these already block an Australis:P1 bug, and being redundant isn't helpful.
Whiteboard: [Australis:P1][Non-Australis-Only] → [Non-Australis-Only]
Target Milestone: --- → Future
Attachment #8346126 - Flags: approval-mozilla-beta?
Attachment #8346126 - Flags: approval-mozilla-beta+
Attachment #8346126 - Flags: approval-mozilla-aurora?
Attachment #8346126 - Flags: approval-mozilla-aurora+
Whiteboard: [Non-Australis-Only] → [Non-Australis-Only][qa-]
You need to log in before you can comment on or make changes to this bug.