"Class is not registered" changing metro default browser/ App reloads when flipping tablet

RESOLVED DUPLICATE of bug 982478

Status

Firefox for Metro
Install/Update
RESOLVED DUPLICATE of bug 982478
4 years ago
4 years ago

People

(Reporter: guigs [guigs] PST (please needinfo me!), Unassigned)

Tracking

28 Branch
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=8)

Steps to reproduce:

1. Install FF 25.01
2. Install Nightly 28.01
3. Make Nightly as default browser
4. Remove Nightly
5. Make FF 25.01 default browser
6. change the default firefox protocols in windows, only the nightly shows and I can not unclick it. When I attempt to click on a link in an email (Windows Live) I get "Class not registered" 

https://support.mozilla.org/en-US/questions/979413
http://forums.mozillazine.org/viewtopic.php?f=23&t=2630261

Actual results:

-Got error message "Class is not registered"
-Side affect of work around is when the newer version of firefox is uninstalled(ie Nightly) the user dated is erased. "Remove my Firefox personal data and customizations " is not selected. 

Expected results:
-Nightly is unclickable in the option to change default browser
-yoga convertible and after the last update, every time I flip to tablet mode every page reloads and as an app where possible. I would be in the middle of something, flip to tablet and lose everything I was working on.

Updated

4 years ago
Blocks: 838081
Whiteboard: [triage]
This will be disabled in bug 940677. The rest of the task and this particular bug can be fixed in v2 when we re-enable the feature once it has some kind of UI that tells users a switch is happening.
Blocks: 842684
No longer blocks: 838081
Blocks: 924860

Updated

4 years ago
Blocks: 861680
No longer blocks: 842684, 924860
Whiteboard: [triage]
Whiteboard: [defect]

Updated

4 years ago
Whiteboard: [defect] → [defect] p=0

Updated

4 years ago
Whiteboard: [defect] p=0 → [defect] p=8

Updated

4 years ago
Target Milestone: --- → Firefox 30

Updated

4 years ago
Whiteboard: [defect] p=8 → p=8 r=ff30
Target Milestone: Firefox 30 → ---

Comment 2

4 years ago
A new comment and attachment was posted to a related bug,
Bug 870312 - Installing Nightly causes "Class not registered" error on click on link in other apps after uninstall  

See bug 870312 comment 4 and attachment 8383392 [details] posted 2014-02-27

Updated

4 years ago
Whiteboard: p=8 r=ff30 → p=8

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 982478
You need to log in before you can comment on or make changes to this bug.