Closed Bug 948199 Opened 7 years ago Closed 7 years ago

[B2G][Browser][YouTube] YouTube.com webpage resolution width is reduced after changing orientation from landscape to portrait

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(firefox29 affected, b2g18 unaffected, b2g-v1.2 unaffected)

RESOLVED DUPLICATE of bug 925026
Tracking Status
firefox29 --- affected
b2g18 --- unaffected
b2g-v1.2 --- unaffected

People

(Reporter: gbennett, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Description:
Switching orientation from portrait to landscape and back lowers the total resolution width starting on the right side to towards the center. Visually it looks like the viewport is reduced to 2/3rds its size. See tester video. If you start youtube.com in landscape and then go to portrait this issue also occurs.

Repro Steps:
1) Updated Buri 1.3 mozRIL to BuildID: 20131209053402
2) Open browser app and go to youtube.com
3) Change orientation to landscape
4) Change orientation to portrait

Actual:
YouTube.com's webpage width is reduced to 2/3rds of origional.

Expected:
YouTube.com is displayed properly in any orientation.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131209053402
Gaia: 1d45d1dc3201059d5c8f2efdeb92c04576d8e161
Gecko: 9f12a9fab080
Version: 28.0a1
RIL Version: 01.02.00.019.102
Firmware Version: 20131115

Notes: This does not repro on latest (12/09) Buri 1.1 mozRIL or Buri 1.2 comRIL. This does not repro on google.com nor kotaku.com which has embedded video and gifs.

Repro frequency: 4/4, 100%
See attached: https://www.youtube.com/watch?v=jUI_LgV_XUo, YouTubeWebpageShrunkReso_LOG.txt
I saw this as well while testing this on today's build - looks like a viewport bug.
blocking-b2g: --- → 1.3?
Component: Gaia::Browser → General
QA Contact: mvaughan
This issue started reproducing on the 10/29 1.3 Buri build.

- Works -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131028040200
Gaia: 31c260b5c853fe78d6bf44c6aeec52a651c3f025
Gecko: 59ff3a2a708a
Version: 27.0a1
Firmware Version: 20131115

- Broken -
Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131029040205
Gaia: 92c097fd7ac9886f937d9decb0e03ab673deaa1b
Gecko: 518f5bff0ae4
Version: 28.0a1
Firmware Version: 20131115
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925026
You need to log in before you can comment on or make changes to this bug.