[BuildScript] Distinguish the usage of PROFILE_DIR and PROFILE_FOLDER

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
10 months ago

People

(Reporter: gweng, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Currently we have these two environment variables in the build system, but they're actually duplicated. This even cause some trouble while I'm dealing with the extension module, which would only put extensions inside GAIA_DIR/PROFILE_FOLDER, rather than PROFILE_DIR, even the later is actually the absolute path.

I can't figure any reason that the relative PROFILE_FOLDER should keep existing, while the absolute one PROFILE_PATH exists. So I fired this bug to discuss and track the issue, and other related issue would block this one if necessary.
Add needinfo to related ones to start the discussion.
Flags: needinfo?(yurenju.mozilla)
Flags: needinfo?(tzhuang)
(Reporter)

Updated

5 years ago
Depends on: 948299
I'm OK with switching to absolute path, but we should ask for opinion from George since he is rewriting JS version of install-gaia.py and he might need PROFILE_FOLDER.
Flags: needinfo?(tzhuang) → needinfo?(gduan)
the major problem for me is PROFILE_FOLDER is also a Make rule in Makefile, if we want to remove this environment variable we need to make sure it can build a workable profile on Mac, Linux & Windows.

BTW, running gaia on nightly browser now is broken on windows and I think the reason is nightly browser updated and something broken, I try to bisect it but I can't find the root cause.
Flags: needinfo?(yurenju.mozilla)
For my case in install-gaia.js, both of absolute path and relative path are ok. I suggest we can use absolute path only and make sure it's compatible in different OS.
Flags: needinfo?(gduan)

Comment 5

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.