Closed Bug 948356 Opened 6 years ago Closed 6 years ago

[SMS] When displaying message options (tap and hold on a message) and the keyboard is open...

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: vittone, Assigned: steveck)

References

Details

Attachments

(2 files)

58.28 KB, image/png
Details
46 bytes, text/x-github-pull-request
borjasalguero
: review+
Details | Review
Attached image sms-overlay.png
Message options must overlay the keyboard.
Actually we can't overlay the keyboard but we can make it disappear.

This is a 1.3 issue.
blocking-b2g: --- → 1.3?
Yes, that could be a solution.
triage: 1.3+ regression
blocking-b2g: 1.3? → 1.3+
Keywords: regression
Note to whoever will take this bug: the solution is to focus the main dialog container in the show() method in action_menu.js, just like we do in attachment_menu.js (see [1]). The dialog needs a tabindex = -1 property (see [2]).

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/js/attachment_menu.js#L46
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/index.html#L216
It's not a regression, the issue happens since the message options have been implemented.
Was implemented in bug 927783.
Blocks: 927783
QA Contact: schung
Attached file Link to github
Hi Borja, I set reviewer to you since this is related to your previous task ;)
Attachment #8349906 - Flags: review?(borja.bugzilla)
Comments on github! :)
(In reply to Borja Salguero [:borjasalguero] from comment #8)
> Comments on github! :)

Julien already explained the idea clearly, applying blur and focus might have no difference to most of the users, but app accessibility will be improved from this patch becuase the correct navigator sequence(if we focus the form first).
Assignee: nobody → schung
QA Contact: schung
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
Comment on attachment 8349906 [details] [review]
Link to github

I thought that I have given r+ before! My fault. R+ taking into consideration the explanation given.
Attachment #8349906 - Flags: review?(borja.bugzilla) → review+
Thanks!
Landed in master: 24bb4bfb0cbad51de8bc3eb014614d1f1c5940ab
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: 1.3 C2/1.4 S2(17jan) → ---
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
Uplifted 24bb4bfb0cbad51de8bc3eb014614d1f1c5940ab to:
v1.3: d91ece211e418ce76dceadf70fd3289568182e74
You need to log in before you can comment on or make changes to this bug.