Element.mozRequestFullScreen() should hide nav buttons on Android 4.4

RESOLVED DUPLICATE of bug 936099

Status

()

Firefox for Android
General
--
enhancement
RESOLVED DUPLICATE of bug 936099
5 years ago
2 years ago

People

(Reporter: Keul, Unassigned)

Tracking

25 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8345224 [details]
test_fullscreen_api.html

Firefox mobile can go in fullscreen (with mozRequestFullScreen()) but don't hide system navigation buttons like Chrome in Android 4.4 (use attached testcase if needed or go to http://fichiers.keul.fr/test_fullscreen_api.html)

Don't forget that it would require to change fullscreen message to say that we must swipe from top(or bottom) to return to normal mode (and not press back button anymore)

If needed, we can add "don't hide system navigation buttons" to preferences or about:config

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 936099
You need to log in before you can comment on or make changes to this bug.