Thumbnail grid is not functional after dragging a site to the tab bar

RESOLVED DUPLICATE of bug 1068354

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1068354
5 years ago
4 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=5)

(Reporter)

Description

5 years ago
Reproducible on: latest Aurora (Build ID: 20131209004003)
Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0
Reproducible on: latest Nightly (Build ID: 20131209053402)
Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0

STR:
1. Launch Firefox with a clean profile.
2. Navigate to at least 9 different websites.
3. Restart.
4. Open a new tab page.
5. Drag a thumbnail to the tab bar.

Expected results: The site is loaded in a new tab and New Tab Page remains functional (no operation on thumbnails can be performed: drag, pin, delete, click).

Actual results: The site is loaded in a new tab and New Tab Page is not functional. 

Notes:
1. Reproducible on Ubuntu and Mac OS X.
2. This issue is a regression - not reproducible on Nightly from 2013-07-24: when the Thumbnail Service landed (bug 870100). I'll update as soon as the regression range is found.
3. New Tab Page is functional after reloading or deleting the dragged thumbnail.
4. If a thumbnail from any position than the first one is dragged, a blank thumbnail is displayed.

Comment 1

5 years ago
Regression range:

Last good nightly: 2013-07-24
First bad nightly: 2013-07-25

Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2013-07-24&enddate=2013-07-25
QA Contact: alexandra.lucinet
Thanks, Alexandra!  There are a few bugs that look relevant: bug 894345, bug 894876, bug 895359.  But the last two were also backed out during that range, so that leaves bug 894345.  I haven't tested to make sure that's the problem, but it seems like a good first guess.

Also removing the bug 870100 block since it's not actually related.
Blocks: 894345
No longer blocks: 870100
Blocks: 950073
Whiteboard: [triage]

Updated

4 years ago
Whiteboard: [triage]

Updated

4 years ago
Whiteboard: p=0

Updated

4 years ago
No longer blocks: 950073
Flags: firefox-backlog+
Whiteboard: p=0 → p=5
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068354
You need to log in before you can comment on or make changes to this bug.