Closed Bug 948485 Opened 6 years ago Closed 6 years ago

FX OS crash in mozilla::dom::PContentParent::SendNuwaFork()

Categories

(Core :: IPC, defect, critical)

25 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla29
blocking-b2g 1.3+
Tracking Status
firefox27 --- wontfix
firefox28 --- fixed
firefox29 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: marcia, Assigned: cyu)

References

Details

(Keywords: crash, regression, Whiteboard: [b2g-crash])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-b43fee1d-b48a-492e-b235-d855c2131210.
=============================================================

Seen while running on Buri, using:

Gaia   c952e2756c03eceb4de6a3eba15651741a62f9e8
SourceStamp df82be9d89a5
BuildID 20131210040206
Version 29.0a1

No firm STR, except when the crash occurred I was operating in the Contacts app. This crash takes down the whole phone.
blocking-b2g: 1.3? → 1.4?
we have experienced the same crash multiple(4) times during today's M-C smoketest, no exact STR are found, crashes happened while testing Contacts, Messages and Camera apps

bug 948471 was written up earlier for that crash, can be duped to this one though sinse it's already  nominated
Duplicate of this bug: 948471
Blocks: Nuwa
Nuwa is targeting 1.3, so moving to 1.3?
blocking-b2g: 1.4? → 1.3?
Keywords: regression
For more information, I think this is a regression in moving some Nuwa-related code into the PreallocatedProcessManager. This can be reproduced by killing the Nuwa process. Maybe the Nuwa process is killed by the lowmem killer under very low memory condition.

The error code path is that PreallocatedProcessManagerImpl::ObserveProcessShutdown() set mPreallocatedAppProcess, instead of PreallocatedProcessManagerImpl::MaybeForgetSpare(), which handles the termination of the Nuwa process.
This issue reproduced in today's Buri 1.3 build while opening Browser app.

Environmental Variables
Device: Buri v 1.3 Mozilla RIL
Build ID: 20131211004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/6bb84d0bc170
Gaia: 7a2ccae2a546ac4d981d250272dafa630c926422
Platform Version: 28.0a2
Firmware Version: V1.2_US_20131115

Crash: https://crash-stats.mozilla.com/report/index/4423a201-330a-43a0-ab34-ca3bc2131211
https://hg.mozilla.org/mozilla-central/rev/e4ba261ab3d0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Ran into this crash today.  Will have to try verifying tomorrow as the patch landed today.
You need to log in before you can comment on or make changes to this bug.