Closed Bug 948531 Opened 6 years ago Closed 6 years ago

Tab switch causes page to first be rebuilt without active layers

Categories

(Core :: Graphics: Layers, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla29

People

(Reporter: BenWa, Assigned: BenWa)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STR:
1) Open http://people.mozilla.org/~bgirard/browser_tests/gpu_bound/?1000
2) Switch to another tab for a few seconds
3) Switch back

You'll see the page first repaint without any active layers for what appears to be two frames then switch to active layers. Making the first 3 frames very jerky.
The problem is also visible on page load (might need to have the image cached).

We don't need to wait at all to predict that this animation will continue.
Problem is here:
http://mxr.mozilla.org/mozilla-central/source/layout/base/ActiveLayerTracker.cpp#207

We should be also be checking if there's an active animation.
Attached patch patchSplinter Review
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #8345460 - Flags: review?(matt.woodrow)
Attachment #8345460 - Flags: review?(matt.woodrow) → review+
Wow, did we really not do this in any way before? Thanks for fixing!
This has the misfortune of landing on top of debug mochitest bustage. Post-backout, OSX 10.6 debug mochitest-5 was orange. Going through what landed (and applicable Try pushes), this was the most likely candidate. Backing out for now. If this turns out to be OK, I will re-land it.
https://hg.mozilla.org/integration/mozilla-inbound/rev/9389007688e1

https://tbpl.mozilla.org/php/getParsedLog.php?id=31833565&tree=Mozilla-Inbound
As predicted by BenWa, this wasn't at fault. Relanded :)

https://hg.mozilla.org/integration/mozilla-inbound/rev/d551609a45a9
https://hg.mozilla.org/mozilla-central/rev/d551609a45a9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Keywords: verifyme
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:29.0) Gecko/20100101 Firefox/29.0

Reproduced on Nightly from 2013-12-09 with STR from comment 0. 
Verified as fixed with Firefox 29 beta 4 (Build ID: 20140331125246) on Mac OS X 10.6: the page repaints with active layers after reloading or switching tabs.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Depends on: 1004417
Depends on: 984939
Depends on: 1023677
You need to log in before you can comment on or make changes to this bug.