Closed Bug 948569 Opened 6 years ago Closed 6 years ago

Disable seer on Beta 27 and Aurora 28

Categories

(Core :: Networking, defect)

27 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
Tracking Status
firefox27 --- disabled
firefox28 --- disabled
firefox29 --- wontfix

People

(Reporter: u408661, Assigned: u408661)

Details

Attachments

(1 file)

Until we have satisfactory solutions for bug 945779 and bug 947745 (harder than it looks), we should disable the seer on beta (and release, of course)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 881804
User impact if declined: possible high CPU usage during page load, unbounded sql disk usage
Testing completed (on m-c, etc.): ensured pref works as advertised
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8345430 - Flags: review?(mcmanus)
Attachment #8345430 - Flags: approval-mozilla-beta?
Attachment #8345430 - Flags: review?(mcmanus) → review+
Comment on attachment 8345430 [details] [diff] [review]
disable_seer.patch

See comment 0 for approval justification.
Attachment #8345430 - Flags: approval-mozilla-aurora?
Summary: Disable seer on beta → Disable seer on beta and aurora
Summary: Disable seer on beta and aurora → Disable speculative connections on Beta 27 and Aurora 28
We have other speculative connections than just those created by the seer :)
Summary: Disable speculative connections on Beta 27 and Aurora 28 → Disable seer on Beta 27 and Aurora 28
Attachment #8345430 - Flags: approval-mozilla-beta?
Attachment #8345430 - Flags: approval-mozilla-beta+
Attachment #8345430 - Flags: approval-mozilla-aurora?
Attachment #8345430 - Flags: approval-mozilla-aurora+
Looks like the tests are not expecting the feature to be disabled.
(In reply to Richard Newman [:rnewman] from comment #5)
> Landed a fix for the test:
> 
> https://hg.mozilla.org/releases/mozilla-beta/rev/ecfaa4a0cd8d

Please land this fix on trunk as well so we don't have to repeat this song and dance on every merge cycle.
Aurora push: remote:   https://hg.mozilla.org/releases/mozilla-aurora/rev/ed83e1080ed0

RyanVM: I'll land the test patch on m-c in a separate bug a bit later (though my plan is to have it be irrelevant for 29 anyway).
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Richard Newman [:rnewman] from comment #3)
> I landed this on Beta.

Thanks for this (and fixing my test-related bustage)!
(In reply to Nicholas Hurley [:hurley] from comment #7)
> RyanVM: I'll land the test patch on m-c in a separate bug a bit later
> (though my plan is to have it be irrelevant for 29 anyway).

Yes, but plans can change so it never hurts to be prepared :)
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.