keyboard preference UI loops infinitely loops infinitely loops infinitely loops...

VERIFIED DUPLICATE of bug 947033

Status

Firefox OS
Gaia::Settings
VERIFIED DUPLICATE of bug 947033
4 years ago
4 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox29 unaffected, b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Reporter)

Description

4 years ago
video: https://vine.co/v/hQQ9dXHU5ge

12/10, master + mozilla-central, Nexus 4
(Reporter)

Updated

4 years ago
Keywords: regression
(Reporter)

Updated

4 years ago
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
This should be device dependent. Can someone test this across 1.2, 1.3, and 1.4 and indicate where this reproduces?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #1)
> This should be device dependent. Can someone test this across 1.2, 1.3, and
> 1.4 and indicate where this reproduces?

Meant to say - device independent.

Comment 3

4 years ago
This issue does not reproduce on the latest 1.2 Buri build, but does reproduce on both the latest 1.3 and 1.4 builds.

1.2 Environmental Variables (Does Not Reproduce):
Device: Buri 1.2 Mozilla RIL
BuildID: 20131212004004
Gaia: 6d02039072a2ae5cf9225a6f4c78ed49decfab5c
Gecko: 8bae10bb0aed
Version: 26.0
Base Image: V1.2_20131115

1.3 Environmental Variables (Does Reproduce):
Device: Buri 1.3 Mozilla RIL
BuildID: 20131212004003
Gaia: 588a3e02c4ace3b3341ba1f6bb7274120b53b2b3
Gecko: 031270be3702
Version: 28.0a2
Base Image: V1.2_20131115

1.4 Environmental Variables (Does Reproduce):
Device: Buri v1.4 Mozilla RIL
BuildID: 20131212040203
Gaia: 8952898bbc98dd31e25b647203791cf129867ff1
Gecko: 1ad9af3a2ab8
Version: 29.0a1
Base Image: V1.2_20131115
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
status-firefox29: --- → affected
Keywords: qawanted → regressionwindow-wanted
QA Contact: jzimbrick

Comment 4

4 years ago
Regression Window:

Last Working Environmental Variables:
Device: Buri v1.3 Mozilla RIL
BuildID: 20131203151100
Gaia: df070d4eed244e782dd3a7c2a7586d0741eac09f
Gecko: 9ac7ed427cd2
Version: 28.0a1
Base Image: V1.2_20131115

First Broken Environmental Variables:
Device: Buri 1.3 Mozilla RIL
BuildID: 20131204040204
Gaia: 45564d6318cdab2fae2de0eb801308e2bcf4e472
Gecko: 9688476c1544
Version: 28.0a1
Base Image: V1.2_20131115
Keywords: regressionwindow-wanted

Updated

4 years ago
blocking-b2g: --- → 1.3?
Component: Gaia::Keyboard → Gaia::Settings
This should be a dup of bug 947033 which is a bug I fixed yesterday.

qawanted to verify if the new build still reproduces.

Sorry about that Dietrich!
Keywords: qawanted
blocking-b2g: 1.3? → 1.3+

Comment 6

4 years ago
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #5)
> This should be a dup of bug 947033 which is a bug I fixed yesterday.
> 
> qawanted to verify if the new build still reproduces.
> 
> Sorry about that Dietrich!

This issue is still reproducing on the latest Mozilla 1.3 Buri build, but does NOT occur on the latest 1.4.

On 1.3, the device is behaving exactly as stated in Comment 0.

1.3 Environmental Variables (Issue still occurring):
BuildID: 20131217004001
Gaia: dca0a3dcf062ce3e422a9c56d141c14543c816fb
Gecko: 1f7db4cc788e
Version: 28.0a2
Base Image: V1.2_20131115

On 1.4, the menus behave as the user would expect them to. Pressing back will take the user back one step, eventually returning them to the main Settings menu.

1.4 Environmental Variables (Issue is NOT occurring):
BuildID: 20131217040201
Gaia: 545aacf3feff6430140cc9ade757002df4895b77
Gecko: b1e5ade62913
Version: 29.0a1
Base Image: V1.2_20131115
Keywords: qawanted

Updated

4 years ago
status-firefox29: affected → unaffected
(In reply to J Zimbrick from comment #6)
> (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from
> comment #5)
> > This should be a dup of bug 947033 which is a bug I fixed yesterday.
> > 
> > qawanted to verify if the new build still reproduces.
> > 
> > Sorry about that Dietrich!
> 
> This issue is still reproducing on the latest Mozilla 1.3 Buri build, but
> does NOT occur on the latest 1.4.
> 

bug 947033 is not yet uplifted on v1.3.
Duplicate of this bug: 949677
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947033

Comment 10

4 years ago
Verified it.
Thanks!

* Build Information:
 - Gaia      5de94a2be6ab8d33434294d70c1de330f55d8f2d
 - Gecko     http://hg.mozilla.org/mozilla-central/rev/c8d5a871ae32
 - BuildID   20140101040201
 - Version   29.0a1

* Result:
  Cannot reproduce
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.