Created attachment 8451246 [details] [review] Pull request This pull requests fixes comments and renames all private methods to have "_" (underscore) prefix. This is the first step to make NfcHandoverManager instantiable. Once it get's approved, I'll do the second part (more intrusive) - refactor to be instantiable - in bug 971519. All unit tests are passing. I've also manually tested it with both emulator and Flame, and handovers are working after applying this patch. Comments are generating correctly using "grunt docs".
Comment on attachment 8451246 [details] [review] Pull request Documenting, renaming and there is no obvious errors Thanks.
Comment on attachment 8451246 [details] [review] Pull request NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings. [Approval Request Comment] [Bug caused by] (feature/regressing bug #): Uplift of 998175 was requested (it's blocking 2.0), and it's easiest to first uplift this one to cleanly apply 998175. [User impact] if declined: There will be more problematic uplift of 998175. [Testing completed]: Unit tests passes, and manually tested NFC handovers on Flame. [Risk to taking this patch] (and alternatives if risky): Don't know any, changes are pretty minor. [String changes made]: