[JSDOC] Refine all not-jsdoc-friendly comments in nfc handover manager

RESOLVED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: alive, Assigned: kamituel)

Tracking

(Blocks: 1 bug)

unspecified
2.0 S6 (18july)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Blocks: 948821
No longer depends on: 948821
Summary: [Meta][JSDOC] Refine all not-jsdoc-friendly comments in nfc manager. → [Meta][JSDOC] Refine all not-jsdoc-friendly comments in nfc handover
(Assignee)

Updated

4 years ago
Assignee: nobody → kamituel
Blocks: 971519
Summary: [Meta][JSDOC] Refine all not-jsdoc-friendly comments in nfc handover → [Meta][JSDOC] Refine all not-jsdoc-friendly comments in nfc handover manager
(Assignee)

Updated

4 years ago
Blocks: 933640
(Assignee)

Comment 1

4 years ago
Created attachment 8451246 [details] [review]
Pull request

This pull requests fixes comments and renames all private methods to have "_" (underscore) prefix.

This is the first step to make NfcHandoverManager instantiable. Once it get's approved, I'll do the second part (more intrusive) - refactor to be instantiable - in bug 971519.

All unit tests are passing. I've also manually tested it with both emulator and Flame, and handovers are working after applying this patch.

Comments are generating correctly using "grunt docs".
Attachment #8451246 - Flags: review?(gweng)
Comment on attachment 8451246 [details] [review]
Pull request

Documenting, renaming and there is no obvious errors Thanks.
Attachment #8451246 - Flags: review?(gweng) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Summary: [Meta][JSDOC] Refine all not-jsdoc-friendly comments in nfc handover manager → [JSDOC] Refine all not-jsdoc-friendly comments in nfc handover manager
master: https://github.com/mozilla-b2g/gaia/commit/9f8d380019c8116153f12557bace3ec65f3a3b64
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S6 (18july)
(Assignee)

Comment 4

4 years ago
Comment on attachment 8451246 [details] [review]
Pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Uplift of 998175 was requested (it's blocking 2.0), and it's easiest to first uplift this one to cleanly apply 998175.
[User impact] if declined: There will be more problematic uplift of 998175.
[Testing completed]: Unit tests passes, and manually tested NFC handovers on Flame.
[Risk to taking this patch] (and alternatives if risky): Don't know any, changes are pretty minor.
[String changes made]:
Attachment #8451246 - Flags: approval-gaia-v2.0?

Updated

4 years ago
Attachment #8451246 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/351d6c295ce210510d0b0210fc830989193d751e
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Blocks: 1047238
You need to log in before you can comment on or make changes to this bug.