Closed Bug 948983 Opened 6 years ago Closed 6 years ago

Desktop and Metro start pages should be compatible when switch between the two

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect, P2)

x86_64
Windows 8
defect

Tracking

(firefox28 verified, firefox29 verified)

VERIFIED FIXED
Firefox 28
Tracking Status
firefox28 --- verified
firefox29 --- verified

People

(Reporter: emtwo, Assigned: emtwo)

References

Details

(Whiteboard: [beta28] p=1)

Attachments

(1 file, 1 obsolete file)

Bug 924886 comment 11 comment 6 and 7 explain what the issue here is
That should be Bug 924886 comment 11, points 6 and 7
Blocks: 924886
Whiteboard: p=1
I'm unsure of the additional check in bindings/browser.js Maybe there's a better way to do that?
Attachment #8345946 - Flags: feedback?(mbrubeck)
Comment on attachment 8345946 [details] [diff] [review]
v1: Make  about:newtab the start page with about:home and about:start as aliases and save all as "about:newtab" in sessionstore

This looks good to me.  Don't forget BrowserUI.isStartURI, and BrowserCLH.js.
Attachment #8345946 - Flags: feedback?(mbrubeck) → feedback+
Assignee: nobody → msamuel
Blocks: metrov1it21
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: p=1 → [beta28] p=1
Attachment #8346589 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/fx-team/rev/b87726cc3c4b
Whiteboard: [beta28] p=1 → [fixed-in-fx-team] [beta28] p=1
https://hg.mozilla.org/mozilla-central/rev/b87726cc3c4b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team] [beta28] p=1 → [beta28] p=1
Target Milestone: --- → Firefox 29
Comment on attachment 8346589 [details] [diff] [review]
v2: Make about:newtab the start page with about:home and about:start as aliases and save all as "about:newtab" in sessionstore

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Part of bug 924860

User impact if declined: switching between metro and desktop will show about:newtab and about:start as invalid urls on metro and desktop respectively

Testing completed (on m-c, etc.): Changes were tested on mc

Risk to taking this patch (and alternatives if risky): low risk, only Metro code is affected

String or IDL/UUID changes made by this patch: none
Attachment #8346589 - Flags: approval-mozilla-aurora?
Attachment #8346589 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Target Milestone: Firefox 29 → Firefox 28
Verified as fixed with latest Aurora 28.0a2 (build ID: 20131223004002) on Win 8 64-bit: while in Desktop mode, after opening 3 tabs (for example: "about:support", "about:newtab"  and cnn.com) I switch to Metro mode, where I can see that all 3 tabs have loaded, including "about:newtab" that opens as "about:start". The viceversa situation is also working, when switching from Metro to Desktop mode.
> Verified as fixed with latest Aurora 28.0a2 (build ID: 20131223004002) on
> Win 8 64-bit: while in Desktop mode, after opening 3 tabs (for example:
> "about:support", "about:newtab"  and cnn.com) I switch to Metro mode, where
> I can see that all 3 tabs have loaded, including "about:newtab" that opens
> as "about:start". The viceversa situation is also working, when switching
> from Metro to Desktop mode.

Also verified with latest Nightly 29.0a1 (build ID: 20131223030203) on Win 8 64-bit.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.