Closed Bug 949191 Opened 6 years ago Closed 6 years ago

[B2G][Browser] unknown cert issuer error message text overlaps the border and the text's letters are too small to read it

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, firefox27 wontfix, firefox28 fixed, firefox29 fixed, b2g-v1.3 verified)

RESOLVED FIXED
1.3 C1/1.4 S1(20dec)
blocking-b2g 1.3+
Tracking Status
firefox27 --- wontfix
firefox28 --- fixed
firefox29 --- fixed
b2g-v1.3 --- verified

People

(Reporter: sarsenyev, Assigned: fabrice)

References

Details

(Keywords: regression, Whiteboard: burirun1.3-1 [systemsfe])

Attachments

(3 files, 1 obsolete file)

Attached image 2013-12-11-14-00-28.png
Description:
When opening the unknown cert issuer page, some text is overlapped

Repro Steps:
1) Updated Buri to BuildID: 20131210004003
2) Open the "Browser" app from the home screen
3) Tap on the URL bar and type: https://cav.receita.fazenda.gov.br/eCAC/Aplicacao.aspx in the browser
4) Observe the text

Actual:
Some text is overlapped

Expected:
The text is not overlapped

Environmental Variables:
Device: Buri 1.3 Aurora Moz RIL
BuildID: 20131210004003
Gaia: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Gecko: e0c328d99742
Version: 28.0a2
Firmware Version: v1.2_20131115

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=6901
See attached: screenshot
Summary: [B2G][Browser] unknown cert issuer error message text overlaps the border → [B2G][Browser] unknown cert issuer error message text overlaps the border and the text's letters are too small to read it
Does this reproduce on 1.1 or 1.2?
Keywords: qawanted
It doesn't reproduce on 1.1 and 1.2 builds, because the design is changed see the attachment

Device: Buri 1.2 Moz RIL
BuildID: 20131211004007
Gaia: 096722a9e2510ecdfe45ba7382d7d50826b82feb
Gecko: 43d7b300241a
Version: 26.0
Firmware Version: v1.2_20131115

Device: Buri 1.1 Moz RIL
BuildID: 20131210041202
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: 05117f42088f
Version: 18.0
Firmware Version: V1.2_20131115
Keywords: qawanted
I think I know what happened here - we might be rendering the desktop design here, rather than the mobile design. This is likely a regression then from bug 882186.
Blocks: 882186
blocking-b2g: --- → 1.3?
Keywords: regression
Component: Gaia::Browser → Gaia::System::Window Mgmt
Whiteboard: burirun1.3-1 → burirun1.3-1 [systemsfe]
Attached patch wip (obsolete) — Splinter Review
We erroneously removed the override for netError.css that is used by certError.xhtml.
This patch reverts this change, but for some unknown reason we still get a mostly unstlyled page.
Attached patch certerror.patchSplinter Review
Ok, I forgot to add the netError.css in jar.mn in the previous patch. This one reverts certerror pages to the old ones.
Assignee: nobody → fabrice
Attachment #8347067 - Attachment is obsolete: true
Attachment #8347077 - Flags: review?(anygregor)
Comment on attachment 8347077 [details] [diff] [review]
certerror.patch

Review of attachment 8347077 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

::: b2g/chrome/content/netError.css
@@ +109,5 @@
> +  padding-left: 15px;
> +  background-image: url("chrome://browser/skin/images/arrowright-16.png");
> +  background-size: 11px 11px;
> +  background-repeat: no-repeat;
> +  background-position: left 0.3em;  

nit: whitespace
Attachment #8347077 - Flags: review?(anygregor) → review+
https://hg.mozilla.org/mozilla-central/rev/58bd8c6d2260
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
Keywords: verifyme
QA Contact: jsmith
blocking+ for cert error regression from error refactoring
blocking-b2g: 1.3? → 1.3+
Depends on: 957838
Looks okay overall with a minor followup in bug 957838.
You need to log in before you can comment on or make changes to this bug.