Notification ".onclick" event is fired twice

RESOLVED DUPLICATE of bug 956276

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 956276
4 years ago
4 years ago

People

(Reporter: pedrocrespo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20131211040203

Steps to reproduce:

* Create a system notification with "navigator.mozNotification.createNotification" or "new Notification".
* Bind an ".onclick" event to the notification.
* Show the notification and tap it.


Actual results:

* The ".onclick" event is fired twice.


Expected results:

* The ".onclick" event should have been fired only once.
Blocks: 950678
This bug blocks a blocker (Bug 950678) so asking for v1.3+ flag
blocking-b2g: --- → 1.3?

Comment 2

4 years ago
This is mostly related to dispatch event in gaia/apps/system/js/notification.js being called twice.

Patch has been submitted in bug 956276(https://bugzilla.mozilla.org/show_bug.cgi?id=956276). 
This should solve the above issue as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 956276

Updated

4 years ago
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.