Status

()

Core
DOM: CSS Object Model
--
trivial
VERIFIED DUPLICATE of bug 49274
17 years ago
17 years ago

People

(Reporter: Preben Holm, Assigned: jst)

Tracking

({verifyme})

Trunk
x86
Windows 2000
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

Using the text-align og vertical-align in the body element can cause that only
text will be aligned the right way and not for example a table. It's kind of
anoying that you have to use the old <center> codes and then have to use the
deprecated codes in HTML 4.01

Reproducible: Always
Steps to Reproduce:


Actual Results:  The element is placed where ever it's set to standard, but the
codes work fine if you create a table that is 100% width and 100% height and
then tells the browser that the table has a vertical-align and a text-align you
can place and element where ever you want...

Expected Results:  The Mozilla web-browser should have centered the table
instead of putting it to the left.

<body style="vertical-align: middle; text-align: center;">

Comment 1

17 years ago
This assumtion about text-align is wrong, it's used to center *text*, not
tables. To center the table using CSS you should use this style on the table: 
{ margin-left: auto; margin-right: auto; }

Marking dup of bug 49274, which is invalid.

*** This bug has been marked as a duplicate of 49274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Yeah, know it works, thanx

But I cannot understand why it works if I put a table in a table, and the table
in the other table can be aligned left, right, top, middle, bottom using the
vertical-align and text-align CSS codes

how come - that thing could probably be an error, that you didn't think about
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
Please provide a test-case to prove what you mean in your last comment as I'm
unable to reproduce the behaviour that you describe.
Just create some simple example html file and add it to this bug with this link:
http://bugzilla.mozilla.org/createattachment.cgi?id=94928
Reporter: this bug is a duplicate as noted before and you all but confirmed with
your latest comment.

Your question asked on 2001-08-13 11:51 should be filed into a new bug if you
still see that behaviour.  Nothing personal, but bugs are meant for one issue
only.  Otherwise we'd have huge bug reports right now if people kept asking one
more question over and over.  :)

Again, marking this a duplicate but if your second issue is still occuring in
the latest nightly builds, please open a new report.  Thanks :)



*** This bug has been marked as a duplicate of 49274 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE

Comment 5

17 years ago
VERIFIED dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.