Closed Bug 949380 Opened 7 years ago Closed 7 years ago

Talos regressions caused by UITour push 166d27bf3b4b

Categories

(Firefox :: General, defect, P1)

29 Branch
All
Linux
defect

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: MattN, Assigned: MattN)

References

()

Details

(Keywords: perf, regression, Whiteboard: [Australis:P1][talos_regression])

Attachments

(2 files, 1 obsolete file)

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Summary: TART regressions caused by UITour push 166d27bf3b4b → Talos regressions caused by UITour push 166d27bf3b4b
I don't have time to wait for a try push and test my theory as it's 2 AM. I'm going to leave it until morning since this is Ubuntu only and it's not clear whether it's the UITour bugs or bug 897074 which needs to be backed out (see http://mzl.la/1grqGDU ).
Keywords: regression
Whiteboard: [Australis:P?]
Version: Trunk → 29 Branch
Priority: -- → P1
Whiteboard: [Australis:P?] → [Australis:P1]
I haven't measured the performance yet as my linux build is still going and I just pushed to Try now but I'm think there's a greater than 50% chance this is the cause and I'd like to get this landed ASAP if it is.
Attachment #8347031 - Flags: review?(bmcbride)
Oops, the try push is https://tbpl.mozilla.org/?tree=Try&showall=1&rev=cfc79f412b15 and I will compare it to (1bc33fa19b24) to see an improvement:

  http://compare-talos.mattn.ca/?oldRevs=1bc33fa19b24&newRev=cfc79f412b15&submit=true

and to the previous m-c base (76551fba7121) to show no regression: 

  http://compare-talos.mattn.ca/?oldRevs=76551fba7121&newRev=cfc79f412b15&submit=true
(In reply to Matthew N. [:MattN] from comment #3)
> and to the previous m-c base (76551fba7121) to show no regression: 
> 
> http://compare-talos.mattn.ca/?oldRevs=76551fba7121&newRev=cfc79f412b15&submit=true

Results look good. The 10% remaining regression on Ubuntu 32 TART is just noise (from looking at the graph).
Oops, incomplete attachment.
Attachment #8347031 - Attachment is obsolete: true
Attachment #8347031 - Flags: review?(bmcbride)
Attachment #8347085 - Flags: review?(bmcbride)
Attachment #8347085 - Attachment description: 949380_talos_v1.patch → v.1 Add @hidden=true initially to UITour panels
Attachment #8347085 - Flags: review?(bmcbride) → review+
https://hg.mozilla.org/mozilla-central/rev/b6dab3694be2
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Whiteboard: [Australis:P1] → [Australis:P1][talos_regression]
You need to log in before you can comment on or make changes to this bug.