Closed Bug 949480 Opened 7 years ago Closed 7 years ago

There is no progress bar present for gingerbread devices in android notification when downloading

Categories

(Firefox for Android :: General, defect)

28 Branch
ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox26 --- unaffected
firefox27 --- affected
firefox28 --- affected
firefox29 --- affected

People

(Reporter: paul.feher, Unassigned)

Details

Attachments

(1 file)

Device: Samsung Galaxy R (Android 2.3.4) 
Build: Aurora 28.0a1 (2013-12-12)

Steps to reproduce:
1. Download a file from (http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android/).
2. Minimize the application an open android notification.
3. Check the download notification.

Expected result:
There should be a progress bar and a percentage showing the download progress.

Actual result:
There is only the percentage displayed.

Note:This is only reproducible on Samsung Galaxy R (Android 2.3.4) not reproducible on (Android 4.+) devices
Works for me. Is this device specific? Gingerbread problem? Can you attach a screenshot.
Summary: There is no progress bar present in android notification when downloading → There is no progress bar present for gingerbread devices in android notification when downloading
Federico, were progress alerts in the download notification implemented with a limitation of the platform API level (i.e, unsupported on 2.3)?
Flags: needinfo?(fedepaol)
I gave a quick look at NotificationCompatBuilder documentation (which is the one we are using here) and it is pretty straightforward about actions: "On platform versions that don't offer expanded notifications, methods that depend on expanded notifications have no effect. [..] action buttons won't appear on platforms prior to Android 4.1" but not that much about progress.

However, looking at the source code (https://android.googlesource.com/platform/frameworks/support/+/refs/heads/master/v4/java/android/support/v4/app/NotificationCompat.java) it looks like progress is not handled in versions older than honeycomb (included).

If we *really* want to have the progress bar I am afraid we need to switch back to the hand made progress indicator in case of pre-hc devices.
Flags: needinfo?(fedepaol)
Probably wontfix for a dying platform
Allow me
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.