Closed Bug 949527 Opened 9 years ago Closed 9 years ago

investigate and fix test_launch_everything_me_app

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bebe, Assigned: alive)

References

Details

Attachments

(1 file)

This is failing with:
test_launch_everything_me_app (test_everythingme_launch_app.TestEverythingMeLaunchApp) ... ERROR

======================================================================
ERROR: None
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/florinstrugariu/.virtualenvs/gaia/local/lib/python2.7/site-packages/marionette_client-0.7.0-py2.7.egg/marionette/marionette_test.py", line 143, in run
    testMethod()
  File "/home/florinstrugariu/gaia/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/everythingme/test_everythingme_launch_app.py", line 32, in test_launch_everything_me_app
    results[0].tap()
  File "/home/florinstrugariu/gaia/gaia/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/search_panel.py", line 69, in tap
    self.wait_for_condition(lambda m: self.apps.displayed_app.name == app_name)
  File "/home/florinstrugariu/gaia/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 103, in wait_for_condition
    raise TimeoutException(message)
TEST-UNEXPECTED-FAIL | test_everythingme_launch_app.py test_everythingme_launch_app.TestEverythingMeLaunchApp.test_launch_everything_me_app | TimeoutException: Condition timed out
----------------------------------------------------------------------
Ran 1 test in 102.436s

FAILED (errors=1)
pdb trace before gaiatest/apps/homescreen/regions/search_panel.py", line 69:

(Pdb) self.marionette.execute_async_script('return GaiaApps.displayedApp();')
{u'origin': u'window:e.me,source:app://homescreen.gaiamobile.org', u'src': None, u'frame': <marionette.marionette.HTMLElement object at 0x1e7ed90>, u'name': None}
Open Settings app, and try to get displayedApp(), it works.
  (Pdb) self.marionette.execute_async_script('return GaiaApps.displayedApp();')
  {u'origin': u'app://settings.gaiamobile.org', u'src': None, u'frame': <marionette.marionette.HTMLElement object at 0x2e3dd90>, u'name': u'Settings'}

Open apps of everything.me, and can not get src and name.
1) Launch e.me's Twitter
  (Pdb) self.marionette.execute_async_script('return GaiaApps.displayedApp();')
  {u'origin': u'window:e.me,source:app://homescreen.gaiamobile.org', u'src': None, u'frame': <marionette.marionette.HTMLElement object at 0x2e3ddd0>, u'name': None}
2) Launch e.me's Facebook
  (Pdb) self.marionette.execute_async_script('return GaiaApps.displayedApp();')
  {u'origin': u'window:e.me,source:app://homescreen.gaiamobile.org', u'src': None, u'frame': <marionette.marionette.HTMLElement object at 0x2e3dd90>, u'name': None}


The possible root cause is the change of AppWindowManager.
https://github.com/mozilla-b2g/gaia/commits/master/apps/system/js/app_window_manager.js
https://github.com/mozilla-b2g/gaia/pull/14635

Try this.
The src part seems also None in settings app. Does this matter?
Try to fix wrapper name
Attachment #8347111 - Flags: feedback?(fyen)
Comment on attachment 8347111 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14635

After cherry-pick 8baa869, and reinstall-gaia, it works fine.
Thank you Alive :)

Now we only assert app's name, so I think it's okay for gaiatest.
Let's trace SRC none issue on Bug 949950.
Attachment #8347111 - Flags: feedback?(fyen) → feedback+
Comment on attachment 8347111 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14635

Askeing, please try again because I change the way it works.
Attachment #8347111 - Flags: review?(timdream)
Attachment #8347111 - Flags: feedback?(fyen)
Attachment #8347111 - Flags: feedback+
Comment on attachment 8347111 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14635

after cherry pick e303c6b and make install gaia, the test_everythingme_launch_app.py works fine.
Attachment #8347111 - Flags: feedback?(fyen) → feedback+
Attachment #8347111 - Flags: review?(timdream) → review+
https://github.com/mozilla-b2g/gaia/commit/45ca653fc8aa2e93b884afc61d31563a25b24eb1
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Assignee: nobody → alive
You need to log in before you can comment on or make changes to this bug.