Closed Bug 949629 Opened 6 years ago Closed 5 years ago

Button play should reload the runtime app

Categories

(DevTools :: WebIDE, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 34

People

(Reporter: ochameau, Assigned: jryans)

References

Details

Attachments

(1 file)

As we can't open an app toolbox/debugger before the app is started,
it is currently really hard (impossible?) to debug app startup code.
You have to work around that by delaying initialization code in order to open a toolbox, set the break point before the code runs.

It's not really clear how we can address that, but that sounds like a quite common usage!
I think I've been able to do this in the past by opening a toolbox and then updating the app.
Duplicate of this bug: 949734
So this now works for imported apps, but not for runtime apps.
The play button should be activated and do a reload.
Summary: Can't debug apps startup code → Button play should reload the runtime app
Maybe change the icon to a reload icon as well ?
Duplicate of this bug: 997827
This has been asked a few times by gaia hackers and some people in the B2G perf team. They want to add breakpoints to startup code. Not sure if we want to introduce a new button, or use the play button with a different image.
Can't we just make the play button reload runtime apps...?  I mean, we can get a new icon later if we want, but let's just make it work at least.

This seems to work for me, but the comments here make me feel like I am missing something. :)

Try: https://tbpl.mozilla.org/?tree=Try&rev=8f844ba99ec2
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #8477588 - Flags: review?(paul)
Attachment #8477588 - Flags: review?(paul) → review+
(In reply to J. Ryan Stinnett [:jryans] from comment #7)
> Created attachment 8477588 [details] [diff] [review]
> Reload runtime apps on play
> 
> Can't we just make the play button reload runtime apps...?  I mean, we can
> get a new icon later if we want, but let's just make it work at least.

Yep. Let's get a reload button: bug 1057958

> This seems to work for me, but the comments here make me feel like I am
> missing something. :)

Nope. That's it.
https://hg.mozilla.org/mozilla-central/rev/76cddd08ee7e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
QA Whiteboard: [qa+]
Verified that apps are reloaded when play button is selected on simulators and a Flame device with 1.4.
Used Aurora 34.0a2 2014-10-08 under Win 7 64-bit, Ubuntu 13.04 64-bit and Mac OSX 10.9.5.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
QA Contact: petruta.rasa
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.