Closed Bug 949829 Opened 7 years ago Closed 6 years ago

[DSDS] Add support for "detected card" state

Categories

(Firefox OS Graveyard :: RIL, defect)

x86
Linux
defect
Not set
normal

Tracking

(blocking-b2g:-, feature-b2g:-)

RESOLVED WORKSFORME
blocking-b2g -
feature-b2g -

People

(Reporter: pgravel, Unassigned)

References

Details

(Whiteboard: [cr 588477])

In a DSDS scenario, there is currently no way to tell the UI that a sim has been detected but no subscription is active yet. This causes the UI to show a no-sim icon on bootup for longer than it should.

Adding a GECKO_CARDSTATE_DETECTED state would allow UI to properly show an empty signal bar rather than a no-sim icon as soon as a sim card is detected.
(In reply to pgravel from comment #0)
> In a DSDS scenario, there is currently no way to tell the UI that a sim has
> been detected but no subscription is active yet. 

I am not sure if I get your ideas. To make sure we are on the same page, maybe you could define 'sim' and 'subscription' here first? Also, could you elaborate on the case that a sim has been detected but no subscription is active? Is 'turning a sim off' an example?

> This causes the UI to show
> a no-sim icon on bootup for longer than it should.
> 
> Adding a GECKO_CARDSTATE_DETECTED state would allow UI to properly show an
> empty signal bar rather than a no-sim icon as soon as a sim card is detected.

If a card is detected, then mozMobileConnections[index].iccId isn't null. |iccchange| event is fired as well while we detect a card in the first place. In this way, having additional GECKO_CARDSTATE_DETECTED state seems redundant.

If UI needs to show the empty signal bar, isn't 'nsIDOMMobilConnection.radioState' or 'nsIDOMMobileConnection.signalStrength' or 'nsIDOMMobileConnection.relSignalStrength' the correct reference?
Whiteboard: [cr 588477]
Move this bug in backlog.
blocking-b2g: --- → backlog
No longer depends on: CAF-v2.0-FC-metabug
feature-b2g: --- → 2.1
(In reply to pgravel from comment #0)
> In a DSDS scenario, there is currently no way to tell the UI that a sim has
> been detected but no subscription is active yet.
It only happens when the options of activating SIM card are provided in firefox OS.

It doesn't happened in current design because we activates all subscriptions in DSDS platform.
That means we can detect if sim is inserted. Moreover, even if we add this, it is useless
without UX change.

By the way, if the options of activating SIM card are expected, please file a user story bug and discuss that bug with UX team first. 

For this bug, I mark this bug invalid.
Status: NEW → UNCONFIRMED
blocking-b2g: backlog → -
feature-b2g: 2.1 → -
Ever confirmed: false
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
(In reply to Ken Chang[:ken] from comment #3)
> (In reply to pgravel from comment #0)
> > In a DSDS scenario, there is currently no way to tell the UI that a sim has
> > been detected but no subscription is active yet.
> It only happens when the options of activating SIM card are provided in
> firefox OS.
> 
> It doesn't happened in current design because we activates all subscriptions
> in DSDS platform.
> That means we can detect if sim is inserted. Moreover, even if we add this,
> it is useless
> without UX change.
> 
> By the way, if the options of activating SIM card are expected, please file
> a user story bug and discuss that bug with UX team first. 
> 
> For this bug, I mark this bug invalid.
Ken, this issue is not only applicable to DSDS scenarios but also happens if for example the selected network type is CDMA but a GSM SIM card is inserted. Since the app is not longer present as per ril_worker.js cardstate of GECKO_CARDSTATE_UNDETECTED will be sent causing the UI to show a no SIM icon which is clearly incorrect.
Reopening as per my previous comment.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
(In reply to Anshul from comment #4)
> Ken, this issue is not only applicable to DSDS scenarios but also happens if
> for example the selected network type is CDMA but a GSM SIM card is
> inserted. Since the app is not longer present as per ril_worker.js cardstate
> of GECKO_CARDSTATE_UNDETECTED will be sent causing the UI to show a no SIM
> icon which is clearly incorrect.
Thanks for raising this issue.  As Hsinyi said in comment 1, Gaia can know if
a SIM card is inserted through checking if iccid is null.  According to what you said,
this design doesn't work now when network type is CDMA and a GSM SIM card is inserted.
Ril should be able to get the iccid from SIM whatever network type is set.
Hsinyi and Edgar are checking this issue. But this issue seems a different problem from
this bug and should have a different description. In order to avoid confusion, I would like
to suggest having another bug to track the issue you mention.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → INVALID
(In reply to Ken Chang[:ken] from comment #6)
> (In reply to Anshul from comment #4)
> > Ken, this issue is not only applicable to DSDS scenarios but also happens if
> > for example the selected network type is CDMA but a GSM SIM card is
> > inserted. Since the app is not longer present as per ril_worker.js cardstate
> > of GECKO_CARDSTATE_UNDETECTED will be sent causing the UI to show a no SIM
> > icon which is clearly incorrect.
> Thanks for raising this issue.  As Hsinyi said in comment 1, Gaia can know if
> a SIM card is inserted through checking if iccid is null.  

Yup, from the perspective of WebAPI design, there's no need to have 'detected' state. But of course, implementation needs to correctly detect the card.

> According to what
> you said,
> this design doesn't work now when network type is CDMA and a GSM SIM card is
> inserted.
> Ril should be able to get the iccid from SIM whatever network type is set.
> Hsinyi and Edgar are checking this issue. But this issue seems a different
> problem from
> this bug and should have a different description. In order to avoid
> confusion, I would like
> to suggest having another bug to track the issue you mention.

Agree that the case when there's no app is a shortcoming of mozRIL. Bug 1013847 has been filed for addressing mozRIL issue. Thank you!
(In reply to Ken Chang[:ken] from comment #6)
> (In reply to Anshul from comment #4)
> > Ken, this issue is not only applicable to DSDS scenarios but also happens if
> > for example the selected network type is CDMA but a GSM SIM card is
> > inserted. Since the app is not longer present as per ril_worker.js cardstate
> > of GECKO_CARDSTATE_UNDETECTED will be sent causing the UI to show a no SIM
> > icon which is clearly incorrect.
> Thanks for raising this issue.  As Hsinyi said in comment 1, Gaia can know if
> a SIM card is inserted through checking if iccid is null.  According to what
> you said,
Ken, if Gaia can find out if the card is detected based on the presence of iccid then the issue originally reported will be fixed. I just tested this scenario again and seems like Gaia is able to handle this well. Thanks.

> this design doesn't work now when network type is CDMA and a GSM SIM card is
> inserted.
> Ril should be able to get the iccid from SIM whatever network type is set.
> Hsinyi and Edgar are checking this issue. But this issue seems a different
> problem from
> this bug and should have a different description. In order to avoid
> confusion, I would like
> to suggest having another bug to track the issue you mention.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
Attached the follow-up Bug 1013847 to 'See also'.
See Also: → 1013847
You need to log in before you can comment on or make changes to this bug.