[Dialer] Rework oncall transition to adapt incoming attention screen change.

RESOLVED DUPLICATE of bug 1068093

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 1068093
4 years ago
3 years ago

People

(Reporter: alive, Assigned: rexboy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Recaping:

* The call screen should not be toggled anymore :) displayed directly and in a proper state
* We should start loading the wallpaper as soon as possible instead of waiting for onload
* We should remove the toggleScreen() function in CallsHandler in favor of an explicit closeScreen() function

We should pay special attention to:
* the opening and closing transition smoothness
* the call ended message
* the postMessage to save in the call log
Feel free to deassign if you're not available. (Discussed offline.)
Assignee: nobody → rexboy
A rough WIP:
https://github.com/rexboy7/gaia/commit/9ecce3e9072ddad5408275e04fa882e37e31b1c0#diff-d92153efec08c1bd2eb8540c4a6a8c31R350

We may try the performance of animation in system app with this WIP first.
Created attachment 8350504 [details]
wip

This patch works on common use cases for me. I'm not sure if I did cleanup completely, so I'll continue look around and see if there's anything need to be cleaned.

Etienne we may need your feedback on this patch.. May you comment if there are any concerns. Thanks a lot!
Attachment #8350504 - Flags: feedback?(etienne)
Comment on attachment 8350504 [details]
wip

Made a suggestion on the patch but I didn't had the system part of the patch to actually try this on a phone :)
Attachment #8350504 - Flags: feedback?(etienne)
Rex, could you please finish this patch? I'd like to complete the attention-window patch.
Flags: needinfo?(rexboy)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068093
Flags: needinfo?(rexboy)
You need to log in before you can comment on or make changes to this bug.